By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,067 Members | 1,297 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,067 IT Pros & Developers. It's quick & easy.

Underlying table not updated

P: 6
Hello,
I've seen a few topics regarding the abovementioned subject, however, I still couldn't get my form to work.

Here's my scenario, I have a form linked to a single table. There are 2 date fields that need to be populated.

1. Date Request Raised
2. Date Allocated

Date Allocated should be defaulted to Date Request Raised. I was able to make it work by setting Default Value to =[Date Request Raised] same as Control Source to Date Request Raised. The problem I'm having at the moment is that Date Allocated field in the underlying table is not being populated.

Is there a way to correct this? Any help would be appreciated.
Oct 8 '08 #1
Share this Question
Share on Google+
3 Replies


NeoPa
Expert Mod 15k+
P: 31,709
It sounds like you may have set the Control Source rather than the Default Value.

I would consider the following approach if the Default Value approach can't work (I'm not sure whether or not it does - but try that approach first) :
Expand|Select|Wrap|Line Numbers
  1. Private Sub Date_Request_Raised_AfterUpdate()
  2.   If Me.NewRecord _
  3.   And IsNull(Me.[Date Allocated]) Then _
  4.     Me.[Date Allocated] = Me.[Date Request Raised]
  5. End Sub
Oct 9 '08 #2

P: 6
Thank you sooooooooooooooooooo much!!!!! It's works!!!!!
Oct 9 '08 #3

NeoPa
Expert Mod 15k+
P: 31,709
I'm very pleased that's helped :)

Welcome to Bytes!
Oct 9 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.