By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,948 Members | 804 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,948 IT Pros & Developers. It's quick & easy.

No warning when deleting records

P: n/a
My Ak2 databas has been running successfully for many years althogh it gets
upgraded regularly.

I now find on this, and other dbs, when I delete a record I no longer get
the message "You are about to delete 1 record.....".
What has gone wrong / got changed?

Thanks Phil
Sep 18 '08 #1
Share this Question
Share on Google+
6 Replies


P: n/a
Phil Stanton wrote:
My Ak2 databas has been running successfully for many years althogh it gets
upgraded regularly.

I now find on this, and other dbs, when I delete a record I no longer get
the message "You are about to delete 1 record.....".
What has gone wrong / got changed?

Thanks Phil

Did you do something like
Docmd.SetWarnings = False
in your code and not reset it back to True?

Sep 18 '08 #2

P: n/a
Hi Salad,
I wondered that and there are a couple of places where that could happen,
but as far as I know, I have never used that bit of code

Anway before trying the delete on a table, I typed DoCmd.SetWarnings True in
the immediate window. Still have the problem

Thanks,
Phil
"Salad" <oi*@vinegar.comwrote in message
news:Ca******************************@earthlink.co m...
Phil Stanton wrote:
>My Ak2 databas has been running successfully for many years althogh it
gets upgraded regularly.

I now find on this, and other dbs, when I delete a record I no longer get
the message "You are about to delete 1 record.....".
What has gone wrong / got changed?

Thanks Phil
Did you do something like
Docmd.SetWarnings = False
in your code and not reset it back to True?

Sep 18 '08 #3

P: n/a
Phil Stanton wrote:
Hi Salad,
I wondered that and there are a couple of places where that could happen,
but as far as I know, I have never used that bit of code

Anway before trying the delete on a table, I typed DoCmd.SetWarnings True in
the immediate window. Still have the problem

Thanks,
Phil
"Salad" <oi*@vinegar.comwrote in message
news:Ca******************************@earthlink.co m...
>>Phil Stanton wrote:

>>>My Ak2 databas has been running successfully for many years althogh it
gets upgraded regularly.

I now find on this, and other dbs, when I delete a record I no longer get
the message "You are about to delete 1 record.....".
What has gone wrong / got changed?

Thanks Phil

Did you do something like
Docmd.SetWarnings = False
in your code and not reset it back to True?
Let's try a test. Create a dummy table. Call it Junk or whatever.
Create 1 field and save the table and enter 4 or 5 records. Now CTRL+A
to select the records and press the Delete key. Do you get the
confirmation message? If so, then I'd add a couple more junk records
and create a temp form on that table and try to delete from the form.
If you don't get the message...time for Allen Browne.
Sep 18 '08 #4

P: n/a
Thanks for coming back, Salad

Created a new DB and Table
Deleted records as suggested and still no warning message.
Lets hope Allen spots this message. In the meantime I think I will remove
Access and reload it in case it has got corrupted..

Why is it I always seem to get unsolvable problems. For example on my Office
machine, running a copy of the same Db as on this machine, FE & BE
situation, I can see all the relationships as normal in the BE Db but
therelationships of the linked tablesdon't show in the FE.. But at least the
warning message appears on that machine.

I suppose the more Dbs I use, the more problems appear

Thanks

Phil

"Salad" <oi*@vinegar.comwrote in message
news:cP******************************@earthlink.co m...
Phil Stanton wrote:
>Hi Salad,
I wondered that and there are a couple of places where that could happen,
but as far as I know, I have never used that bit of code

Anway before trying the delete on a table, I typed DoCmd.SetWarnings True
in the immediate window. Still have the problem

Thanks,
Phil
"Salad" <oi*@vinegar.comwrote in message
news:Ca******************************@earthlink.c om...
>>>Phil Stanton wrote:
My Ak2 databas has been running successfully for many years althogh it
gets upgraded regularly.

I now find on this, and other dbs, when I delete a record I no longer
get the message "You are about to delete 1 record.....".
What has gone wrong / got changed?

Thanks Phil

Did you do something like
Docmd.SetWarnings = False
in your code and not reset it back to True?

Let's try a test. Create a dummy table. Call it Junk or whatever. Create
1 field and save the table and enter 4 or 5 records. Now CTRL+A to select
the records and press the Delete key. Do you get the confirmation
message? If so, then I'd add a couple more junk records and create a temp
form on that table and try to delete from the form. If you don't get the
message...time for Allen Browne.


Sep 19 '08 #5

P: n/a
Go to Tools - Options - Edit/Find Tab - Confirm - check Record changes,
document deletions, Action queries.
Phil Stanton wrote:
>Thanks for coming back, Salad

Created a new DB and Table
Deleted records as suggested and still no warning message.
Lets hope Allen spots this message. In the meantime I think I will remove
Access and reload it in case it has got corrupted..

Why is it I always seem to get unsolvable problems. For example on my Office
machine, running a copy of the same Db as on this machine, FE & BE
situation, I can see all the relationships as normal in the BE Db but
therelationships of the linked tablesdon't show in the FE.. But at least the
warning message appears on that machine.

I suppose the more Dbs I use, the more problems appear

Thanks

Phil
>>Hi Salad,
I wondered that and there are a couple of places where that could happen,
[quoted text clipped - 25 lines]
>form on that table and try to delete from the form. If you don't get the
message...time for Allen Browne.
--
Please Rate the posting if helps you

Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200809/1

Sep 19 '08 #6

P: n/a
Brilliant. So simple. I should have kicked myself for not spotting it,
though how it got changed, I don't know

Thanks a lot

Phil
"AccessVandal via AccessMonster.com" <u18947@uwewrote in message
news:8a6b19c4f1cf8@uwe...
Go to Tools - Options - Edit/Find Tab - Confirm - check Record changes,
document deletions, Action queries.
Phil Stanton wrote:
>>Thanks for coming back, Salad

Created a new DB and Table
Deleted records as suggested and still no warning message.
Lets hope Allen spots this message. In the meantime I think I will remove
Access and reload it in case it has got corrupted..

Why is it I always seem to get unsolvable problems. For example on my
Office
machine, running a copy of the same Db as on this machine, FE & BE
situation, I can see all the relationships as normal in the BE Db but
therelationships of the linked tablesdon't show in the FE.. But at least
the
warning message appears on that machine.

I suppose the more Dbs I use, the more problems appear

Thanks

Phil
>>>Hi Salad,
I wondered that and there are a couple of places where that could
happen,
[quoted text clipped - 25 lines]
>>form on that table and try to delete from the form. If you don't get the
message...time for Allen Browne.

--
Please Rate the posting if helps you

Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200809/1

Sep 19 '08 #7

This discussion thread is closed

Replies have been disabled for this discussion.