By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,963 Members | 2,122 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,963 IT Pros & Developers. It's quick & easy.

Truncation of an SQL memo field

P: 2
I have an access database, 2000, linked to SQL tables.

The primary SQL table includes some memo fields.

When I open the table in access, the memo fields are shown in full but when I include that field in a query the field is truncated to 255 characters.

The query selects all the fields from the main table and adds other information from other tables.

I have tried using a query to make a local copy of the table but the same truncation occurs.

As it happens with more than one record, I have dismissed the possibility of a rogue character in the original table.

Does anyone know the reason for the trunaction and a solution/work-around?

Thanks
Sep 5 '08 #1
Share this Question
Share on Google+
3 Replies


NeoPa
Expert Mod 15k+
P: 31,344
I'd only be guessing (I never need to use Memo fields), but have you tried processing through your data with a recordset.

DAO is the default, but try both. I expect ADODB is the more likely to handle it without truncation.
Sep 5 '08 #2

missinglinq
Expert 2.5K+
P: 3,532
Allen Browne has an article that explains the causes for this phenomenon and gives some workarounds as well:

http://allenbrowne.com/ser-63.html

Welcome to Bytes!

Linq ;0)>
Sep 5 '08 #3

NeoPa
Expert Mod 15k+
P: 31,344
Thanks Linq.

I was struggling there ;-D
Sep 5 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.