By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,952 Members | 923 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,952 IT Pros & Developers. It's quick & easy.

Access datasheet view - jumps back to first fow, when typing

P: 19
Hi all

I have a problem using datasheet in a subform (Access 2007).

When the user is updating numbers or text in a column, and jumps to the next record using the 'Enter' button, sometimes, but not allways, and with no consistency, the cursor jumps back to the first row, which of course is very annoying for the user when entering many numbers in a row.

Any ideas of why Access seems to do this, and what I can do to prevent if from happening....?
Thanks
Best regards
Ingrid
Aug 31 '08 #1
Share this Question
Share on Google+
4 Replies


missinglinq
Expert 2.5K+
P: 3,532
Does your form have code behind it?

DoCmd.GoToRecord , , acFirst


will cause Access to return to to the first record.

Me.Requery


or some variation on this will cause the same thing to happen.

So the first thing I'd do is go to the code module behind your form and use
search to hunt for either acFirst or Requery and see if either of these are present.

Also, in Design View, goto Tools - Options - Keyboard and see what Enter Behavior is set to.

Linq ;0)>
Aug 31 '08 #2

NeoPa
Expert Mod 15k+
P: 31,342
As Linq has implied, this is not the sort of behaviour you'd expect to see normally in a data grid. Ergo, there is probably some code behind the scenes explicitly telling it to do this.
Sep 1 '08 #3

P: 19
Hi again
There doesnt seem to be any code behind the forms, however the form is a subform linked to an other form, and I tried removing the link between the two and that seems to do the trick, it was probably re-linking the subform to the top form, and that was probably what caused the problems. Thanks for your input on this matter.... :-)
Sep 7 '08 #4

NeoPa
Expert Mod 15k+
P: 31,342
Good for you Ingrid :)

Glad you got it sorted.
Sep 7 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.