By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,688 Members | 1,888 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,688 IT Pros & Developers. It's quick & easy.

Relationships corrupt

P: n/a
Sorry to repost this but I now seem to have the BE datbase corrupted.

I have a FE, BE database on my home computer and a duplicate on the office
computer. Both use Ak2 on Windows XP. The one at home appears normal.

The BE consists of about 50 tables with numerous relationships and the FE 9
tables (fixed set up stuff) + the 50 linked table from the BE database. At
home on the relationship view I see all the tables and their relationships,
but on the office machine I see only the relationships between the FE
tables. Show all tables does nothing.
If I try adding the missing BE tables they appear in the Relationship window
without the "_1" suffix as if the table were shown twice, so they apparently
aren't hidden somewhere. If I try to set up a relationship, the various
options are greyed out as I would expect as you can't edit relationships for
tables held in the BE DB in the front end.
Compact & Repair has done no good (both Back End and Front End) Creating 2
new DBs and importing everything has equally failed. Has Access gone
corrupt?

New Info:- In Query design on the office computer, the links between the PK
& FK in tables appear as a thin line whereas at home, there are the 2 thick
ends of the link with 1 1 at one end and an ? at the other

In addition I added a member to the member table (via a member form on th
FE.) The member - Mr R Woods appears OK in the table, but if I run a query
SELECT Member.*
FROM Member
WHERE (((Member.MemSurName) Like "Woo*"));
I get Wood, Woodhouse but No Woods. I tried deleting the name Woods and
re-inputing it in case there was a not printable character hidden there, but
no change.
Mr Woods does not appear on the Member form either.

Deleting the record and re-inputing has cured the problem.

Thanks

Phil

Jun 27 '08 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.