By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,679 Members | 2,469 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,679 IT Pros & Developers. It's quick & easy.

Top option group button will not activate

P: n/a
Hi

I'm having a very strange problem and need HELP!!

I have a form for the user to choose a report (radio button in an
option group) and parameters (Dates, Season).

Click the option button, it turns Black, and the "On Got Focus" event
fires. The event shows or hides the parameters appropriate for that
report.

I have done this process (successfully) many times, but this time, the
TOP option button will NEVER get focus. It won't turn black. I have
changed it to "Visible = No" and put the same info in option #3, and
then Option #2 won't turn black (and option #3 will work flawlessly).

I am CLUELESS - and Desperate! Am hoping someone can help!

Can post code or email mdb. Access 2000.

Thanks -
sara
Jun 27 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Tue, 27 May 2008 08:44:12 -0700 (PDT), sara wrote:
Hi

I'm having a very strange problem and need HELP!!

I have a form for the user to choose a report (radio button in an
option group) and parameters (Dates, Season).

Click the option button, it turns Black, and the "On Got Focus" event
fires. The event shows or hides the parameters appropriate for that
report.

I have done this process (successfully) many times, but this time, the
TOP option button will NEVER get focus. It won't turn black. I have
changed it to "Visible = No" and put the same info in option #3, and
then Option #2 won't turn black (and option #3 will work flawlessly).

I am CLUELESS - and Desperate! Am hoping someone can help!

Can post code or email mdb. Access 2000.

Thanks -
sara
1) Are you sure the 'top' button is actually in the option group and
not just sitting underneath or on top of it?

2) Why are you using an OptionGroup's OnGotFocus event rather than the
OptionGroup's AfterUpdate event (since as soon as you click on a
button the OptionGroup value has been updated?

If Me.OptionName = 1 then
'Do the 1 thing
Elseif Me.OptionName = 2 then
' Do the 2 thing
Else
' Do the default thing
End If
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Jun 27 '08 #2

P: n/a
On May 27, 12:06*pm, fredg <fgutk...@example.invalidwrote:
On Tue, 27 May 2008 08:44:12 -0700 (PDT), sara wrote:
Hi
I'm having a very strange problem and need HELP!!
I have a form for the user to choose a report (radio button in an
option group) and parameters (Dates, Season).
Click the option button, it turns Black, and the "On Got Focus" event
fires. The event shows or hides the parameters appropriate for that
report.
I have done this process (successfully) many times, but this time, the
TOP option button will NEVER get focus. *It won't turn black. *I have
changed it to "Visible = No" and put the same info in option #3, and
then Option #2 won't turn black (and option #3 will work flawlessly).
I am CLUELESS - and Desperate! *Am hoping someone can help!
Can post code or email mdb. *Access 2000.
Thanks -
sara

1) Are you sure the 'top' button is actually in the option group and
not just sitting underneath or on top of it?

2) Why are you using an OptionGroup's OnGotFocus event rather than the
OptionGroup's AfterUpdate event (since as soon as you click on a
button the OptionGroup value has been updated?

If Me.OptionName = 1 then
* * * * 'Do the 1 thing
Elseif Me.OptionName = 2 then
* * * * ' Do the 2 thing
Else
* * * * ' Do the default thing
End If
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail- Hide quoted text -

- Show quoted text -
Great! So this worked - thanks.

I don't know why I did it the other way - figured that out somehow,
and it worked, so I stuck with it.

BUT WHY doesn't the button go active - the old way I was doing it? I
am thinking the button has to "become active" before the code could
execute (On Got Focus), but I don't understand why the top button
(always IN the frame) would not go active?

Thanks - at least now I can deliver this report!
sara
Jun 27 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.