By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,572 Members | 959 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,572 IT Pros & Developers. It's quick & easy.

A97 append query failure reported to be based on broken validation rule?

P: n/a
MLH
Anyone remember if A97 append query failure would ever report
data breaking validation rule when such was not the case. I have
an old SQL statement - several years old now. I've encountered
a case in which the append fails and the reported error is validation
rule.

The table being appended to (tblClusters) has only 1 field with a
validation rule: [MinimumBatchQty], with Byte Field Size property
setting. The validation rule is >0. The field's default value property
at the table level is 2. The SQL does not include a reference to
that field. I put one in there with a fixed value of 3. Query still
failed with same reported error.

I've added 3 fields in recent months. But neither of them have
validation rule settings. Only the one field does. Have any of you
ever known A97 to report validation rule violation when referential
integrity violation was really the issue? I'm grasping for straws
here. I just don't know where to check.

Sleepless in Anytown.
Jun 27 '08 #1
Share this Question
Share on Google+
1 Reply


P: n/a
MLH
Hey! I found it. The REQUIRED setting.

Sneaky though. A97 complains of Validation Rule violation. It would be
more helpful if it were to complain of Required Property setting
violation. Its up to the developer to figure it out. Oh well.
Jun 27 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.