By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,105 Members | 2,620 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,105 IT Pros & Developers. It's quick & easy.

Access DB (& .ldb file) does not close after crystal reports

P: n/a
Hi! We have a VB application using Crystal Reports 6 that has worked
successfully on hundreds of systems for over 10 years. Now, on one
network, the application and access database does not close. It seems
to hang on the [.Close] command.

When we open the application an peruse the screens without opening up
a report (using crystal reports), the application and access db closes
fine. But as soon as we run a report and then close the report and try
to close the application, the access db does not close. Many of the
screens open the db and grab data from the access db, but it's only
after running crystal reports that we have this problem. (Please see
more information below.)

Setup: Application and data (access 97 db) reside on a server in the
same folder, but application shortcut is kicked off on client PC.
Kicking off the shortcut on the client PC means that the image/process
runs on the client PC (not on the server). In this problem case, the
application shortcut is on a Windows XP Pro Version 2002 SP2 PC with
the app & data on a Windows 2003 server. Users are local Admins on
their PCs with "Full Control"over the directory and files on the
server where the data (access 97 db) resides. This type of setup is
typical and has worked without any problems for clients.

The application is written in Visual Basic, using Crystal Reports 6
(using DAO). We close the recordset, set it to zero and then it hangs
on closing the db (.Close command).

A few key pieces of information:

- The application closes fine if the app & data (access 97 db) are on
a local PC. This includes closing fine if the application is run
directly on the Windows 2003 server where the data is stored.

- It worked on this client's network until sometime in the last few
weeks.

- One thing that changed is that the company is using VMWare on its
servers. Not sure if they started using VMWare at the same time as it
started failing. This may be unrelated. Possibly other things changed,
but can't get any more information ... yet.

- It works fine running the application from a Windows Vista PC with a
user who is a domain admin.

- The access db and application hang for about 10-20 minutes and then
eventually closes. It appears that somehow

Crystal Reports is keeping the db open, but I'm not sure why.The
application doesn't quit and the database doesn't close even if I try
to end the task with the Task Manager.

- The Crystl32.ocx version being used is 8.0.0.4 (if that matters).

- I copied 6 month old program files and database files to a test
folder on the Windows 2003 server. It fails using these files that
worked fine 6 months ago.

Any ideas or help would be greatly appreciated! If you know of another
good place to post this, please let me know.

Thanks!

- Mark
Jun 27 '08 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.