By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,662 Members | 1,765 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,662 IT Pros & Developers. It's quick & easy.

input mask error troubleshooting

P: 2
Hi,

I have a problem with one of my form. I want to record some data in a table by using a form. One of those data it is the time and I want to use an input mask to be sure that everyone will enter the data in the same way. There is my problem:

After the first digit I'm entering in the field, the message error "The value you entered isn't appropriate for the input mask '99:00\ >LL;0;_' specified for this field" appears. I'm pressing "OK" and the same error appear immediately. I'm pressing "OK" a second time and everything works well after that, I can continu to fill my field. So I don't understand why I cannot complete the field before the error appears and why it appears twice.

If someone can help me, it will be appreciate.

Thank you

guig
May 28 '08 #1
Share this Question
Share on Google+
3 Replies


NeoPa
Expert Mod 15k+
P: 31,271
What Input Mask are you using (Exactly)?

I used '99:00\ >LL;0;_' and it worked perfectly for me (I did have to position the cursor to the left first).

PS. You don't say what data you attempted to input. Mine was 1111am (11:11 AM was shown).
May 29 '08 #2

missinglinq
Expert 2.5K+
P: 3,532
I did the same as you, NeoPa, with the same results. In point of fact, if an incorrect character was entered, such as an alpha character in the first position instead of a numeric character, what should have occured would be that no character would appear and, depending on your system settings, a warning beep or some such would sound. The warning message should only come up when you exit the textbox. Which makes me think about corruption. I'd delete then recreate the textbox.

Welcome to Bytes, Guig!

Linq ;0)>
May 29 '08 #3

P: 2
Hi Guys

Thanks for your answers...

I deleted the text box to check for corruption and my problem is still there.

I'm tring to enter the same type of data than you NeoPa, medium time. But after 1 digit, numeric one, the error message appear even if I don't exit the textbox. It's like if I have an event to refresh my data every time I write something. But I removed all filter and sort, check all event (nothing), and I still have the problem. Maybe this can help you too... Sometime, but not every time, after I exit my first textbox, the row of this data move up, but not my cursor, so if I write data in the second textbox, I overwrite on my last data row. Not sure if is clear...

ID Time Moisture
48 2:05 am 9.52
49 2:16 am 10.47
50 2:28 am 9.01
*

If I'm entering a new data (ID 51), when I exit the first textbox, than happen:

ID Time Moisture
48 2:05 am 9.52
51
49 2:16 am 10.47
50 |2:28 am 9.01
*
my cursor appers on second textbox of last row (ID 50)

I hope this could help you to help me...

Thanks and have a nice day

guig
Jun 4 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.