By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,475 Members | 2,093 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,475 IT Pros & Developers. It's quick & easy.

How to view query results in subform???

P: 48
Good Morning again everyone,

I am having trouble understanding how to display the results from my query in a subform instead of it opening a separate window.

I have a form that queries a table (Created_Submitted) based on the contents of a combo box. I finally got that working fine yesterday. What I need to do now is get it to show the same informaiton returned in a subform. I am sorry but I have no idea how to proceed. I have tried to find the answer online, in manuals and using Access help but to no avail.

I have tried to figure out a way to requery but don't know how to code that. The subform will display only after I run the initial query (using a command button on my form) and then switch from form view to design view and back.

As always, any help would be greatly appreciated.

Thanks,
Doug
May 8 '08 #1
Share this Question
Share on Google+
4 Replies


NeoPa
Expert Mod 15k+
P: 31,186
Have you started by setting the RecordSource of the subform to the name (or even SQL) of the query?

You will almost certainly want to set the Master- & Child- link fields to tie it in to the main form too I expect.
May 8 '08 #2

P: 48
Yes the RecordSource has already been set to the query. I will lok at the Master & Child Link and let you know.

Thanks

Have you started by setting the RecordSource of the subform to the name (or even SQL) of the query?

You will almost certainly want to set the Master- & Child- link fields to tie it in to the main form too I expect.
May 8 '08 #3

P: 48
So I set the RecordSource for the main from and then created the subform using the same query as the RecordSource. I linked them by the title field and then tried to run it.

The results still pull up a separate window but the subform does not update at all.

Getting very confused. Subforms are completely new to me.

Thanks,
Doug

Have you started by setting the RecordSource of the subform to the name (or even SQL) of the query?

You will almost certainly want to set the Master- & Child- link fields to tie it in to the main form too I expect.
May 8 '08 #4

NeoPa
Expert Mod 15k+
P: 31,186
I'm afraid that, while I suspect you're doing something wrong Doug, I don't really have the information to point to where.

It's a frequently encountered Catch-22 situation :-
If you knew what you were getting wrong you'd know the information I needed :(
May 8 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.