By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,197 Members | 975 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,197 IT Pros & Developers. It's quick & easy.

Sudden DLL Errors

FireMedic
P: 18
I tried to continue a development project on a workstation in our satellite firehall tonight and suddenly am getting a "ERROR LOADING DLL" message when I try to open my main form. If I klick OK it takes me to Break Mode in the VBA editor but any attempt to write or edit code is met with the same error. This is new and hopefully just on this machine as I used my normal workstation last night without any difficulties. I have used this one almost as often also without difficulty until now. I am getting the same message on several other projects I have tested tonight. I do not have admin access to this machine.

I checked the References and found "Microsoft Office Web Components 9.0" marked MISSING but I am not using this ref to the best of my knowledge. That DLL is where the path says it should be however.

Any ideas? Could be this insane system I have to work with... I'm at a loss.
Thanks All
Apr 22 '08 #1
Share this Question
Share on Google+
3 Replies


missinglinq
Expert 2.5K+
P: 3,532
People who understand the inner workings of Access tell me that a missing reference can mess up functions that you wouldn't think they affect, i.e. a Web Component s library messing up a db that doesn't do anything with the Web! Here are Doug Steele's instructions on how to troubleshoot reference problems:

********************* Quote ********************

Any time functions that previously worked suddenly don't, the first thing to suspect is a references problem.

This can be caused by differences in either the location or file version of certain files between the machine where the application was developed, and where it's being run (or the file missing completely from the target machine). Such differences are common when new software is installed.

On the machine(s) where it's not working, open any code module (or open the Debug Window, using Ctrl-G, provided you haven't selected the "keep debug window on top" option). Select Tools | References from the menu bar. Examine all of the selected references.

If any of the selected references have "MISSING:" in front of them, unselect them, and back out of the dialog. If you really need the reference(s) you just unselected (you can tell by doing a Compile All Modules), go back in and reselect them.

If none have "MISSING:", select an additional reference at random, back out of the dialog, then go back in and unselect the reference you just added. If that doesn't solve the problem, try to unselect as many of the selected references as you can (Access may not let you unselect them all), back out of the dialog, then go back in and reselect the references you just unselected. (NOTE: write down what the references are before you delete them, because they'll be in a different order when you go back in)

For far more than you could ever want to know about this problem, check out

http://www.accessmvp.com/djsteele/AccessReferenceErrors.html

Just so you know: the problem will occur even if the library that contains the specific function that's failing doesn't have a problem.

******************* End Quote ******************

Welcome to bytes!

Linq ;0)>
Apr 22 '08 #2

FireMedic
P: 18
Thank Linq.

I had the help desk replace the DLL with a copy I took from another machine. Still shows as missing so I copied it to my Dbase development folder on my network drive and selected that one through the references dialogue and it works fine now. Go figure.

Thanks again.
Apr 25 '08 #3

missinglinq
Expert 2.5K+
P: 3,532
Glad you got it fixed! I know that having a DDL in the same folder as the app sometimes helps. I've never seen an explanation as to why it's sometimes necessary and sometimes not!

Linq ;0)>
Apr 25 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.