By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,575 Members | 3,016 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,575 IT Pros & Developers. It's quick & easy.

DateAdd result to show only once in report

P: 21
Can any one point me in the right direction here...

I have a report that shows an entry and under that record there are several sub records...best way to explain it is imagine an order with several items in that order entry.

I have placed a DateAdd feature in a report that will show me 90 days after the date order was made.

My problem lies in that the DateAdd feature is now showing multiple times under each order...it lists the same DateAdd feature under each item in that main order. For example I have an order that has 10 items in it, the DateAdd feature is showing 10 times...I only want it to show once.

How can I fix this on my report?

Any help would be greatly appreciated!
Apr 15 '08 #1
Share this Question
Share on Google+
2 Replies


JustJim
Expert 100+
P: 407
Can any one point me in the right direction here...

I have a report that shows an entry and under that record there are several sub records...best way to explain it is imagine an order with several items in that order entry.

I have placed a DateAdd feature in a report that will show me 90 days after the date order was made.

My problem lies in that the DateAdd feature is now showing multiple times under each order...it lists the same DateAdd feature under each item in that main order. For example I have an order that has 10 items in it, the DateAdd feature is showing 10 times...I only want it to show once.

How can I fix this on my report?

Any help would be greatly appreciated!
Hi,
Depending on your grouping levels, you need to put the date control one level above the grouped items (this can be physically above or below depending on whether you use the header or the footer). If you can't see header or footer divider bars on the design view of your report, click on the "Grouping and Sorting" icon in the toolbar and say Yes to header and footer for the group of your suborder.

Did that make any sense? I'm on a train and I'm never at my best on a train.

Jim
Apr 15 '08 #2

P: 21
Thanks much for your help...I did look at the Sort/Group option however I found a much easier solution...

In the Properties Sheet I just selected the option of "Hide Duplicates" to Yes instead of the default of No.

Thanks again...
Apr 15 '08 #3

Post your reply

Sign in to post your reply or Sign up for a free account.