By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,148 Members | 774 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,148 IT Pros & Developers. It's quick & easy.

Default Indexes on TransferText Method?

P: n/a
Hello All,

Why does Access (2003) create indexes on importing a CSV file to a
table when using the TransferText Method in VB when the specification
name does NOT have any indexes indicated?

Similar syntax used is as follows:
DoCmd.TransferText acImportDelim, "SpecName", "TblName",
"FileNamePath", True

The specification (i.e. SpecName) has "No" indicated for indexes yet
the table created has indexes after the import is completed. A quick
look at the fields where indexes are created end with "ID", so this
may have something to do with it. Not sure but thought that I'd
mention it.

TIA!

--
Regards,

Greg Strong
Mar 29 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
"Greg Strong" <ne*********@geedubeeu.com.invalidwrote in message
news:vh********************************@4ax.com...
Hello All,

Why does Access (2003) create indexes on importing a CSV file to a
table when using the TransferText Method in VB when the specification
name does NOT have any indexes indicated?

Similar syntax used is as follows:
DoCmd.TransferText acImportDelim, "SpecName", "TblName",
"FileNamePath", True

The specification (i.e. SpecName) has "No" indicated for indexes yet
the table created has indexes after the import is completed. A quick
look at the fields where indexes are created end with "ID", so this
may have something to do with it. Not sure but thought that I'd
mention it.

TIA!

--
Regards,

Greg Strong
Go to Tools -Options -Tables/Queries and check out the option 'AutoIndex
on Import/Create'...
Mar 30 '08 #2

P: n/a
On Sat, 29 Mar 2008 23:58:36 -0000, "Stuart McCall"
<sm*****@myunrealbox.comwrote:
>Go to Tools -Options -Tables/Queries and check out the option 'AutoIndex
on Import/Create'...
Thanks! The indexes are gone on the table auto build.

Somewhat related: I received complaints on the length of time the
queries ran at the end of the month. I always used indexes to speed
things up, however when I create them I use them. In this instance
numerous indexes were created on the source tables of the tables linked.

If numerous fields are indexed but not used in the source tables and
queries are ran from another mdb file does this create overhead and
slow down the queries?

TIA!

--
Regards,

Greg Strong
Mar 31 '08 #3

P: n/a
"Greg Strong" <ne*********@geedubeeu.com.invalidwrote in message
news:a1********************************@4ax.com...
On Sat, 29 Mar 2008 23:58:36 -0000, "Stuart McCall"
<sm*****@myunrealbox.comwrote:
>>Go to Tools -Options -Tables/Queries and check out the option
'AutoIndex
on Import/Create'...

Thanks! The indexes are gone on the table auto build.

Somewhat related: I received complaints on the length of time the
queries ran at the end of the month. I always used indexes to speed
things up, however when I create them I use them. In this instance
numerous indexes were created on the source tables of the tables linked.

If numerous fields are indexed but not used in the source tables and
queries are ran from another mdb file does this create overhead and
slow down the queries?

TIA!

--
Regards,

Greg Strong
The only answer I can give is: probably. I don't know enough (ie hardly
anything) about JET internals to help with this. Perhaps someone else can
jump in?
Mar 31 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.