By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,495 Members | 1,110 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,495 IT Pros & Developers. It's quick & easy.

I need help with versions

P: 2
I'm developing an application at home, and I have some problems to make it work in the user's computer.
I'm using access 2003, the default in my computer was to create databases in 2000 format, so I've converted my database to 2002-2003 format (with 'Convert Databases' in 'Database Utilities').
My user has Access 2003 installed in her computer, and she gets a lot of error messages before be able to open it. I've tried to work in her computer, but when I try to insert a command button I get this error:

Compile error.in query expression 'AppLoadString([bw_tblBtnActions].[Description])'.

Please help!!!
Mar 6 '08 #1
Share this Question
Share on Google+
3 Replies


Denburt
Expert 100+
P: 1,356
Well I found a lot of people out there seem to be having a similar error. First what are the errors she has when they first open the db? Sounds like it might have to do with a missing reference. My first suggestion is to open the VBA window and compile the VBA code (debug/compile) while on the users computer. If there is an error there repost then we can go from there. If there were no errors there then we can move on.

One poster stated that they had changed one of the references located in the VBA section (tools/references). Check to make sure none that are checked are marked as "Missing".

I removed the Microsoft ActiveX Data Objects 2.1 Library reference and added Microsoft ActiveX Data Objects 2.8 in its place and the problem went away. Maybe this will help someone else.
Also while on the users P.C. create a new database and see if this new db can add buttons using the wizard.

One option that worked for another user was to uninstall Office then reinstalled.

Keep us updated thanks.
Mar 6 '08 #2

P: 2
It worked!!! thank you so much!!!
I replaced the Microsoft ActiveX Data Objects 2.1 Library reference with Microsoft ActiveX Data Objects 2.8 as recommended in the comment you quoted.
Mar 8 '08 #3

Denburt
Expert 100+
P: 1,356
You are quite welcome glad I could help... :)
Mar 9 '08 #4

Post your reply

Sign in to post your reply or Sign up for a free account.