469,954 Members | 1,793 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,954 developers. It's quick & easy.

Forms not behaving when opened in Access 2007!

6
I recently made the switch from Access 2003 to Access 2007. The rest of our office is still operating on 2003, so the database is still a 2003 file. We're having trouble with a few forms that work fine when I open them on the 2003 computers, but not on mine (2007 version).

For example. I have a form that is a simple form linked to a solicitation table. It has a combo box that allows the user to select the solicitation they want to look at. After that selection is made, the other fields on the form are populated, and a linked subform that was empty on opening is now refreshed and populated with the names of all the people who got the solicitation. This works great in 2003. In the 2007 version, I can't open the form without getting prompts for the query fields in the subform that are supposed to retrieve data from the table fields on the main form. Any thoughts?

The other trouble is with a form that allows the user to enter two dates, to retrieve all payments that were made between a certain time period. The user enters the dates, and then clicks a control to run a make-table query that provides names and mailing information to generate thank you letters. Works great in 2003. In the 2007 version, I get an error message that says "the database engine could not find the object '1'" I don't even have an object named '1'. Any suggestions?

Are there a lot of bugs like this that others are encountering?
Feb 8 '08 #1
1 1430
puppydogbuddy
1,923 Expert 1GB
I recently made the switch from Access 2003 to Access 2007. The rest of our office is still operating on 2003, so the database is still a 2003 file. We're having trouble with a few forms that work fine when I open them on the 2003 computers, but not on mine (2007 version).

For example. I have a form that is a simple form linked to a solicitation table. It has a combo box that allows the user to select the solicitation they want to look at. After that selection is made, the other fields on the form are populated, and a linked subform that was empty on opening is now refreshed and populated with the names of all the people who got the solicitation. This works great in 2003. In the 2007 version, I can't open the form without getting prompts for the query fields in the subform that are supposed to retrieve data from the table fields on the main form. Any thoughts?

The other trouble is with a form that allows the user to enter two dates, to retrieve all payments that were made between a certain time period. The user enters the dates, and then clicks a control to run a make-table query that provides names and mailing information to generate thank you letters. Works great in 2003. In the 2007 version, I get an error message that says "the database engine could not find the object '1'" I don't even have an object named '1'. Any suggestions?

Are there a lot of bugs like this that others are encountering?
If you haven't done so, you need to upgrade to SP1, which will eliminate a lot of the bugs. Nonetheless, there are still some bugs that have to be dealt with.

See these links:

http://allenbrowne.com/Access2007.html#Compatibility

http://allenbrowne.com/Access2007.html#Bugs
Feb 9 '08 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

12 posts views Thread by Casey | last post: by
5 posts views Thread by anony | last post: by
3 posts views Thread by AFKAFB | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.