By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,509 Members | 1,710 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,509 IT Pros & Developers. It's quick & easy.

Disable Access Security Notice

P: 20
I'm trying to put a link on a database form, but access keeps throwing a warning message when I click it:

"A potential security concern has been identified,

this location may be unsafe."

The help mentions unchecking an option in the trust center, but the option isn't listed for me. The link points at a directory in a subfolder of the database's folder, which is listed as a trusted site along with its subdirectories.

Any suggestions?
Jan 29 '08 #1
Share this Question
Share on Google+
17 Replies


MMcCarthy
Expert Mod 10K+
P: 14,534
What version of Access are you using?

One thing you might try is going to Tools - Macro - Security and make sure the option is set to medium.
Feb 5 '08 #2

mshmyob
Expert 100+
P: 903
2 ways of doing it. If you are using Access 2007 :

Click on the BIG office button in the top left
Select Access Options
Select Trust Center
Select Trust Center Settings
Select Trusted Locations and add your new trusted location.

This works if you never change the directory where the fiels are located. But if you are using it on a network and people can install anywhere or if you use the RUNTIME you need to change the registery setting.

If you want the registery setting change let me know. The registry setting will turn off this message forever no matter what. It is what I use when I distribute an app to end users with the runtime module.

Just a note that if you distribute with the runtime and you use linked files and people can install wherever they want you will need to implement a feature to allow relinking of the data file(s).

I'm trying to put a link on a database form, but access keeps throwing a warning message when I click it:

"A potential security concern has been identified,

this location may be unsafe."

The help mentions unchecking an option in the trust center, but the option isn't listed for me. The link points at a directory in a subfolder of the database's folder, which is listed as a trusted site along with its subdirectories.

Any suggestions?
Feb 5 '08 #3

P: 20
Thanks for the replies, I'm using Access 2007.

I've got the database root folder listed as a trusted location, with the subdirectories option ticked, but I'm still getting the warning.

I might have to try the registry method, but ideally I want the database to be portable and installable anywhere.

I'm worried that users will see the message and not want to access the help pages.
Feb 7 '08 #4

mshmyob
Expert 100+
P: 903
If you use the runtime it will always give you that message no matter what unless you modify the registry.

Thanks for the replies, I'm using Access 2007.

I've got the database root folder listed as a trusted location, with the subdirectories option ticked, but I'm still getting the warning.

I might have to try the registry method, but ideally I want the database to be portable and installable anywhere.

I'm worried that users will see the message and not want to access the help pages.
Feb 7 '08 #5

mshmyob
Expert 100+
P: 903
Here is how you disbale it using the registry for Access 2007

Expand|Select|Wrap|Line Numbers
  1. REGEDIT4
  2.  
  3. [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Access\Security]
  4. "VBAWarnings"=dword:00000001
  5.  
Just create a text file put these 3 lines in and save it as anything you want but have an extension of .REG.

Then just double clik on it and it will modify the registry to get rid of that annoying message.
Feb 7 '08 #6

P: 20
Here is how you disbale it using the registry for Access 2007

Expand|Select|Wrap|Line Numbers
  1. REGEDIT4
  2.  
  3. [HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Access\Security]
  4. "VBAWarnings"=dword:00000001
  5.  
Just create a text file put these 3 lines in and save it as anything you want but have an extension of .REG.

Then just double clik on it and it will modify the registry to get rid of that annoying message.
I added the code to the registry, but it still gives the warning message, even after restarting Windows.
Feb 8 '08 #7

mshmyob
Expert 100+
P: 903
Are you running XP or Vista?

Check your registry manually and see if the change took effect.

I added the code to the registry, but it still gives the warning message, even after restarting Windows.
Feb 8 '08 #8

mshmyob
Expert 100+
P: 903
I just noticed that the code has some spaces in the word Access. This appeared when I added it to theScripts

Make sure Access is one word with no spaces.

I added the code to the registry, but it still gives the warning message, even after restarting Windows.
Feb 9 '08 #9

P: 20
I'm running XP, and the code is in there with no spaces.

I have Access installed separately (no other office apps), if that makes a difference.

Here's a screenshot from regedit:

http://www.oyis.org/screenshotRegedit.png
Feb 12 '08 #10

mshmyob
Expert 100+
P: 903
Try this:

In Registry Editor, locate the following registry subkey: HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\C ommon


1. Click the registry subkey, point to New on the Edit menu, and then click Key.
2. Type Security, and then press ENTER to name the key.
3. On the Edit menu, point to New, and then click DWORD Value.
4. Type DisableHyperlinkWarning, and then press ENTER to name the entry.
5. In the right pane, right-click DisableHyperlinkWarning, and then click Modify.
6. In the Edit DWORD Value dialog box, click Decimal, and then type 1 under Value data.

Note A value of 0 enables the hyperlink warning message. A value of 1 disables the hyperlink warning message.
7. Click OK.
8. Exit Registry Editor.



I'm running XP, and the code is in there with no spaces.

I have Access installed separately (no other office apps), if that makes a difference.

Here's a screenshot from regedit:

http://www.oyis.org/screenshotRegedit.png
Feb 12 '08 #11

attagata
P: 1
Thanks MSHMYOB, It works for me.

OS. Windows XP (Portuguese/Japanese)
ACCESS RUNTIME 2007


Adding in windows registry:
Code: ( text )
REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security]
"VBAWarnings"=dword:00000001

Thanks a lot.
Anderson
Feb 21 '08 #12

mshmyob
Expert 100+
P: 903
You're welcome..........

Thanks MSHMYOB, It works for me.

OS. Windows XP (Portuguese/Japanese)
ACCESS RUNTIME 2007


Adding in windows registry:
Code: ( text )
REGEDIT4

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security]
"VBAWarnings"=dword:00000001

Thanks a lot.
Anderson
Feb 21 '08 #13

P: 20
Works for me too, thanks!
Mar 13 '08 #14

P: n/a
I have win XP SP3. i created the registry file with the 3 lines of code and then double-clicked the file. I received a message saying that the registry was successfully updated. and now my applications running on Access 2007 runtime no longer display the Security Notice dialog box. Thanks for all your help!
Oct 11 '10 #15

mshmyob
Expert 100+
P: 903
You are welcome. It is always nice to see that older posts are still helpful to users.

cheers,
Oct 11 '10 #16

P: 4
Thanks mshmyob. I have just signed on to say that. New security key method works for Office 10 Access (Office\12.0 in registry) also. Unfortunately, the user still has three clicks to wade through in IE as my html help files are so dangerous.

Cheers
Nov 1 '11 #17

mshmyob
Expert 100+
P: 903
LOL - glad it worked for you. Got to watch out for those nasty help files.

cheers,
Nov 3 '11 #18

Post your reply

Sign in to post your reply or Sign up for a free account.