By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,828 Members | 2,241 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,828 IT Pros & Developers. It's quick & easy.

SQL table links to Access as read only

P: n/a
Hi,
I am using SQL Server 2000 as part of SBS 2003. I have an Access 2003
front end for my application. I have many tables linked to Access
from
SQL (using ODBC) which work fine, but now I have just tried to link a
new table I have created and it will only link as read only (i.e. If I
try to add
a new record I can't because the asterisk at the bottom is grey out).

My table only has two fields, and one is set as the primary key in
SQL. Any ideas why this is happening? All of my other tables link ok.

I've also posted this on a SQL server newsgroup, because I'm not sure
if it's Access, SQL or ODBC. Apologies if you get this twice,

Thanks
Colin

Sep 10 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Mon, 10 Sep 2007 12:39:37 -0000, Bobby <bo****@blueyonder.co.uk>
wrote:

Did you set the PK after you linked the table? Delete the link and try
again.

-Tom.

>Hi,
I am using SQL Server 2000 as part of SBS 2003. I have an Access 2003
front end for my application. I have many tables linked to Access
from
SQL (using ODBC) which work fine, but now I have just tried to link a
new table I have created and it will only link as read only (i.e. If I
try to add
a new record I can't because the asterisk at the bottom is grey out).

My table only has two fields, and one is set as the primary key in
SQL. Any ideas why this is happening? All of my other tables link ok.

I've also posted this on a SQL server newsgroup, because I'm not sure
if it's Access, SQL or ODBC. Apologies if you get this twice,

Thanks
Colin
Sep 10 '07 #2

P: n/a
On 10 Sep, 14:46, Tom van Stiphout <no.spam.tom7...@cox.netwrote:
On Mon, 10 Sep 2007 12:39:37 -0000, Bobby <bob...@blueyonder.co.uk>
wrote:

Did you set the PK after you linked the table? Delete the link and try
again.

-Tom.

Thanks Tom,
That's the answer. It's been a long day........

Colin

Sep 10 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.