423,867 Members | 1,958 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 423,867 IT Pros & Developers. It's quick & easy.

Access 2007 Runtime Security Issue

P: n/a
My Access 2007 file fails to open on a machine with the 2007 Access
runtime version installed. It comes up with a Security alert message.
Is there a security setting in the Access Database that needs to be
enabled to run the code and macros?

Aug 13 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
As a security measure, by default Windows will not allow databases
created on external and untrusted machines to automatically open. It's
probable that you need to authorize the Access application.

In Windows explorer, Right-click on the .mdb or .mde file and select
'Properties'. On the General tab there should be a button to authorize
your application to open.

Ron, King of Chi
On Aug 13, 6:29 am, Rocky <consult...@randalstewart.comwrote:
My Access 2007 file fails to open on a machine with the 2007 Access
runtime version installed. It comes up with a Security alert message.
Is there a security setting in the Access Database that needs to be
enabled to run the code and macros?

Aug 13 '07 #2

P: n/a
On Aug 13, 4:51 pm, King Ron <KingRonPoindex...@covad.netwrote:
As a security measure, by default Windows will not allow databases
created on external and untrusted machines to automatically open. It's
probable that you need to authorize theAccessapplication.

In Windows explorer, Right-click on the .mdb or .mde file and select
'Properties'. On the General tab there should be a button to authorize
your application to open.

Ron, King of Chi

On Aug 13, 6:29 am, Rocky <consult...@randalstewart.comwrote:
MyAccess2007file fails to open on a machine with the2007Access
runtimeversion installed. It comes up with a Security alert message.
Is there a security setting in theAccessDatabase that needs to be
enabled to run the code and macros?- Hide quoted text -

- Show quoted text -
Thanks Ron. I have opened the properties/security tab and given all
users full permission and re-booted the system.
Still comes up with the same message.

Aug 14 '07 #3

P: n/a
Hi Rocky,

"Rocky" <co********@randalstewart.comschrieb im Newsbeitrag
news:11*********************@q4g2000prc.googlegrou ps.com...
On Aug 13, 4:51 pm, King Ron <KingRonPoindex...@covad.netwrote:
>As a security measure, by default Windows will not allow databases
created on external and untrusted machines to automatically open. It's
probable that you need to authorize theAccessapplication.

In Windows explorer, Right-click on the .mdb or .mde file and select
'Properties'. On the General tab there should be a button to authorize
your application to open.

Ron, King of Chi

On Aug 13, 6:29 am, Rocky <consult...@randalstewart.comwrote:
MyAccess2007file fails to open on a machine with the2007Access
runtimeversion installed. It comes up with a Security alert message.
Is there a security setting in theAccessDatabase that needs to be
enabled to run the code and macros?- Hide quoted text -

- Show quoted text -

Thanks Ron. I have opened the properties/security tab and given all
users full permission and re-booted the system.
Still comes up with the same message.
The security system changed in A2007.
You have to determine a Trusted Location (folder) for your accdb.
In full version that's done by adding the place to a list under Access
options. Runtime has no office menu button. So you have to add the folder to
the registry manually adding a locations key, e.g.:

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location1]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo1"

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location2]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo2"

Ciao, Sascha
Aug 14 '07 #4

P: n/a
On Aug 14, 11:15 am, "Sascha Trowitzsch" <n...@moss-soft.dewrote:
Hi Rocky,

"Rocky" <consult...@randalstewart.comschrieb im Newsbeitragnews:11*********************@q4g2000prc .googlegroups.com...


On Aug 13, 4:51 pm, King Ron <KingRonPoindex...@covad.netwrote:
As a security measure, by default Windows will not allow databases
created on external and untrusted machines to automatically open. It's
probable that you need to authorize theAccessapplication.
In Windows explorer, Right-click on the .mdb or .mde file and select
'Properties'. On the General tab there should be a button to authorize
your application to open.
Ron, King of Chi
On Aug 13, 6:29 am, Rocky <consult...@randalstewart.comwrote:
MyAccess2007file fails to open on a machine with the2007Access
runtimeversion installed. It comes up with a Security alert message.
Is there a security setting in theAccessDatabase that needs to be
enabled to run the code and macros?- Hide quoted text -
- Show quoted text -
Thanks Ron. I have opened the properties/security tab and given all
users full permission and re-booted the system.
Still comes up with the same message.

The security system changed in A2007.
You have to determine a Trusted Location (folder) for your accdb.
In full version that's done by adding the place to a list underAccess
options.Runtimehas no office menu button. So you have to add the folder to
the registry manually adding a locations key, e.g.:

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location1]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo1"

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location2]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo2"

Ciao, Sascha- Hide quoted text -

- Show quoted text -
Thanks. It worked

I also had to include an autoexec makro to open the switchboard at
startup. Access 2007 does not seem to have a simple way of automating
startup, as dis Access 2002/3

Aug 15 '07 #5

P: n/a
On Aug 15, 4:52 am, Rocky <consult...@randalstewart.comwrote:
On Aug 14, 11:15 am, "Sascha Trowitzsch" <n...@moss-soft.dewrote:
Hi Rocky,
"Rocky" <consult...@randalstewart.comschrieb im Newsbeitragnews:11*********************@q4g2000prc .googlegroups.com...
On Aug 13, 4:51 pm, King Ron <KingRonPoindex...@covad.netwrote:
>As a security measure, by default Windows will not allow databases
>created on external and untrusted machines to automatically open. It's
>probable that you need to authorize theAccessapplication.
>In Windows explorer, Right-click on the .mdb or .mde file and select
>'Properties'. On the General tab there should be a button to authorize
>your application to open.
>Ron, King of Chi
>On Aug 13, 6:29 am, Rocky <consult...@randalstewart.comwrote:
MyAccess2007file fails to open on a machine with the2007Access
>runtimeversion installed. It comes up with a Security alert message.
Is there a security setting in theAccessDatabase that needs to be
enabled to run the code and macros?- Hide quoted text -
>- Show quoted text -
Thanks Ron. I have opened the properties/security tab and given all
users full permission and re-booted the system.
Still comes up with the same message.
The security system changed in A2007.
You have to determine a Trusted Location (folder) for your accdb.
In full version that's done by adding the place to a list underAccess
options.Runtimehas no office menu button. So you have to add the folder to
the registry manually adding a locations key, e.g.:
[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location1]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo1"
[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted
Locations\Location2]
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "C:\MyTrustedDatabaseFolderNo2"
Ciao, Sascha- Hide quoted text -
- Show quoted text -

Thanks. It worked

I also had to include an autoexec makro to open the switchboard at
startup. Access 2007 does not seem to have a simple way of automating
startup, as dis Access 2002/3
In Access 2007, open up the program, click on the office button. At
the bottom is a button for acces options. Pic current or this data
base. Select the startup screen.

Sep 5 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.