By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,504 Members | 1,584 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,504 IT Pros & Developers. It's quick & easy.

Updating Values of Listbox

P: n/a
I have a form in which I would link the form fields to tables in the
SQL database. Right now, I want to put in a listbox that will show
three columns from a table called IssueAudit.

The conditions for my listbox are:

1. The three columns (dubbed as Change History) are taken from
IssueAudit under conditions that the ChangedFields value is 'CATE' -
category.
2. The SAF-NO, a FK is the same key as the SAF_NO primary key in SAF
table.

The outer part of the form uses values from SAF table.
So far, I've managed to get all the values in IssueAudit where
ChangedFields is 'CATE'. But I'm stuck at the point where I can't get
the listbox to show the values corresponding to the record's SAF_NO
even if I tried to move a record back and forth. It just remains there
static.

Is there any step that I need to do? Was there something that I missed
out previously?

Any help on this would be appreciated.

Jun 5 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Jun 5, 10:38 am, melvincw...@gmail.com wrote:
I have a form in which I would link the form fields to tables in the
SQL database. Right now, I want to put in a listbox that will show
three columns from a table called IssueAudit.

The conditions for my listbox are:

1. The three columns (dubbed as Change History) are taken from
IssueAudit under conditions that the ChangedFields value is 'CATE' -
category.
2. The SAF-NO, a FK is the same key as the SAF_NO primary key in SAF
table.

The outer part of the form uses values from SAF table.
So far, I've managed to get all the values in IssueAudit where
ChangedFields is 'CATE'. But I'm stuck at the point where I can't get
the listbox to show the values corresponding to the record's SAF_NO
even if I tried to move a record back and forth. It just remains there
static.

Is there any step that I need to do? Was there something that I missed
out previously?

Any help on this would be appreciated.
use the requery method on the listbox
me.listbox.requery

Jun 6 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.