By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,418 Members | 1,328 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,418 IT Pros & Developers. It's quick & easy.

Graph in Report always displaying Current Year

P: 31
Hello Everyone, I am almost completed with this database, the only thing left is to graph the results of a query. I built a parameter query that gives me totals for a date range that I enter. This works great. I created a column called "Month", and I am entering the month and year corresponding to the "Date" field. ie. (03/15/06 for the date) (Mar-06) for Month. If I do the Query to show me 1/1/2006 to 12/31/2006, I get the results with Date ascending, and the column for Month also ascends from Jan - Dec.
Now my problem is with the Graph. I set the Months as my "X" axis, and the total's as the "Y". I am running the Graph off of the query, and when I put the Date range in, it comes back with all the months in the correct order, but all of them have 07 as the year, no matter what range I put in. formatted the Month column as Text, but it still converts to a date in the graph, and alway's 07.
Any ideas on how to have it actually give me the correct range, just like the query does?
Thank you in advance,
Nick
May 25 '07 #1
Share this Question
Share on Google+
2 Replies

P: 31
Thanks Everyone, I just figured it out. I didn't need the Month field after all, the Graph allowed me to use the Date field, and display it as Month.
Oh how I love programming.
Thanks Again,
Nick
May 25 '07 #2

NeoPa
Expert Mod 15k+
P: 31,770
That's a quicker response than most of our experts manage ;)
Pleased you're sorted anyway.
May 26 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.