By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,946 Members | 773 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,946 IT Pros & Developers. It's quick & easy.

MS Access Error "...unable to rename the form, report, or module"

P: 8
For some unknown reason my mdb seemed to drop a module I had named "Utilities". I tried to copy the module back in from a backup copy and got the error message "<<MyProject>> is currently unable to rename the form, report, or module to 'Utilities' ... Close the database, reopen it, and try the rename operation again." This didn't work. It seemed that other modules could still be renamed normally, but this one - "Utilities" - could not. I could not create a new module with this name but could create a new module with anything similar but slightly different (i.e "Utilitie" or "Utilities1"). I did a Database "Compact and repair" but the problem persisted. I also shut everyting down and reopened and the problem persisted. However, if I created a new mdb and copied the module into it, the copy worked fine and I had no problem renaming it normally.
I came to the conclusion that the problem mdb had become corrupted or that system tables became corrupted. I am now writing a program to copy all the elements of the "bad" mdb to a newly created mdb. Is there something easier I could do to either recover the original file which "disappeared" or at least get it to accept a backup module of the original name. Is there some general way to tell if and how your mdb has become corrupted?
Apr 25 '07 #1
Share this Question
Share on Google+
3 Replies


pks00
Expert 100+
P: 280
sometimes corrupted modules are just not recoverable.
u could try a decompile to see if that helps any
http://www.granite.ab.ca/access/decompile.htm
Apr 26 '07 #2

NeoPa
Expert Mod 15k+
P: 31,342
If you can get back the code from a backup then you can recreate the module. Best to do this after a Compact & Repair though.
Apr 26 '07 #3

P: 8
sometimes corrupted modules are just not recoverable.
u could try a decompile to see if that helps any
http://www.granite.ab.ca/access/decompile.htm
I tried the decompile but it didn't work. I did find that there were some problems in tryng to compile from debug and found the program in the module could be seen when editing (even though the module name had disappeared from the modules list) so I copied the module over to a backup of the original. I didn't find any explanation for the problem though.
Apr 30 '07 #4

Post your reply

Sign in to post your reply or Sign up for a free account.