By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,665 Members | 1,406 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,665 IT Pros & Developers. It's quick & easy.

MS Access 2000 Database Problem with Vista

yolenman
P: 3
Hello -

This is my first posting to this group, so please bear with me. Also note, that while I'm intelligent, databases are not in my field of knowledge.

I'm working with a small limousine company. They presently have about 4 networked computers, all running Windows XP (w/SP2) and Microsoft Office 2000 (specifically Access 2000) - and a plain jane p3 server also running Windows XP (w/sp2) with Office 2000 loaded onto it.

These networked computers are accessing an Access 2000 .mdb file, in a multi-user fashion (more then one user is accessing this shared file at any given time) from the above mentioned server. This file is their customer database, used to run their business.

It should be noted, that this customers MUST use Access 2000, as using Access XP (2002 ?) as above causes the database to do weird things, such as create blank records, or input records that are non –contiguous. At one time, an Access database guru told me why Access XP (2002) does this, but I cannot recall the details - plus it was some time ago.

Moving forward -

This company recently purchased 4 new Dell E520's (Dual Core P4's) with the new lovely (smirk) Windows Vista 32 bit Business OS preinstalled on them.

I have installed these 4 new Dell E520 systems and networked them with the above mentioned server. All the normal stuff is working, Internet , etc etc.

I then installed (don't laugh or joke) Office 2000, just to check things out.

Now - they are no longer able to launch the Access database file (that lives on the above mentioned server), in a multi-user fashion any longer.

Example: if one user opens the file, no other networked users can open the file on the server. When the second or subsequent user double clicks the Alias to launch the database file, Vista's little blue ring goes around a few times, but nothing ever happens.

if user one exits the file, then the next subsequent user can then open the database file, but the next subsequent user cannot. so on and so forth.

Your saying to yourself - well duh - upgrade it to a newer version of Acess right? - even though it has some issues (as identified above).

Yes - I did that. I then installed and tested with Office XP (2002), Office 2003 (w/SP2), and lastly, Office 2007.

All yielded the same results, I cannot run the file in a muli-users fashion, as before in the XP environment.

I tried setting the msaccess compatibility mode to both Windows XP SP2 and Windows 2000 (for each verion of the Office apps above) - still no luck.

I tried seeting msaccess to run in Admin mode (on all above versions) - no luck

I tried Admin mode & the above compatibility mode options together - no luck.

I tried updating the access 2000 .mdb database file to the Access 2003 format using the Access 2003 conversion tool, and attempted to perform all the above testing routine again - even with Office 2007 - Still no multi-user support.

At this point - I'm at a loss to get this to work, so I have come here seeking guidance, answers, help, etc etc.

Can anyone offer me some input as to why I'm unable to run this file in a multi-user fashion under Vista and (pick your version of Office), as I used to be able to do in the XP enviroment ?

Any assistance would be greatly appreciated.

Thanks

Leonard
Mar 21 '07 #1
Share this Question
Share on Google+
13 Replies


MMcCarthy
Expert Mod 10K+
P: 14,534
Hi Leonard

Open Access. Go to Tools - Options and set the Default Open Mode to Shared. When you reinstalled Access it probably reset to Exclusive. Also make sure that the Default Record Locking is set to Edited Record.

Mary
Mar 21 '07 #2

yolenman
P: 3
Hi Leonard

Open Access. Go to Tools - Options and set the Default Open Mode to Shared. When you reinstalled Access it probably reset to Exclusive. Also make sure that the Default Record Locking is set to Edited Record.

Mary
Hi Mary -

I checked the settings as you pointed out. It was already set to Shared, and I made the change to Edited Record. It does not seem to help - only 1 user can access the mdb file at a time....

Any other ideas ?
Mar 22 '07 #3

MMcCarthy
Expert Mod 10K+
P: 14,534
Hi Leonard

We have had a couple of other posters on with similar issues. One of whom solved their problem initally by removing IE7. The then discovered this.

http://windowsxp.mvps.org/networkfile.htm

It seems IE7 and probably Vista are treating mde's as executable files. Anyway see if this helps to resolve your problem.

Mary
Mar 22 '07 #4

P: 3
I have an Access application that is the 2002-2003 version and I am experiencing the exact same problem. I really don't want to remove IE7. Does Microsoft know about this?
Apr 16 '07 #5

ADezii
Expert 5K+
P: 8,607
Hi Mary -

I checked the settings as you pointed out. It was already set to Shared, and I made the change to Edited Record. It does not seem to help - only 1 user can access the mdb file at a time....

Any other ideas ?
For testing purposes only, and only with a reliable backup, eliminate the Front End/Back End architecture. Import all Objects from the Front End DBs into the Server Back End, set it to Shared Usage, then see if it will now allow multiuser access. If it does, it may be some sort of connectivity issue with the Front Ends.
Apr 16 '07 #6

P: 3
More things that don't work! I trie removing ie7 and replacing it with firefox. It didn't help!!!
Apr 21 '07 #7

P: 47
I'm pretty sure with Vista's patch guard working in the background at all times making sure nothing gets it's hooks into the kernel the shared function which should have been turned on by default as everything else is in Microsoft you need to 'downgrade' to IE6, at least that's what we need to run in the c-lab at school to enable file share. IE7's new security features interfere with file share and a number of other programs we use such as MML's due to active X issues. I am far and away from an expert, but I listen and watch and this sounds like the same issues they're going through at school. Everyone will need to dump their hardware and move to a 64 bit platform in order to gain compatibility when changing over to Vista, or have headache's constantly. Good luck to you. Joe
Apr 21 '07 #8

P: 3
Here is a temporary workaround that may help.

I tested mt Access 2003 application today with two other computers one with Windows xp Professional and the other with Windows Xp Home edition. I first ran the application locally on the computer with Vista Home Premium then had the other two computers which are on a local LAN run the application at the same time and they ran OK including file updates.

I logged into the vista system as a user (not administrator) when I ran the Access application.

I installed Office Professional on the Vista computer
The two XP computers are running Office 2003 Professional

I set the folder to share for everybody with no password, and permissions to Read and Execute, Read, Write, and List files

I set the application to Read and Execute, Read, Write, etc.

Good Luck
Apr 24 '07 #9

P: 1
SLK
I'm having the same probem with two Vista Home Premium computers which are networked and running Access 2003 in an Access 2000 mode. It appears that you have to open the Access database in a certain order. If I open the database from the Main computer (where the database resides in its public folder) I cannot open the database from that same public folder on the other Vista machine. The Vista ring just spins until I close the database from the Main computer and then the database opens from the other computer and then I can open the database from the Main computer and share the database. However, I'm worried about corruption and I probably going to the hotfix listed in Microsoft's KB Article No. 935366 because I have also received database corruption errors. I've also added the Main computer to the trusted sites in IE7 and it did get rid of the security notice, but didn't resolve the problem.
Apr 26 '07 #10

P: 1
Hi There,

I have a similiar problem and a workaround

I have a network of 15 xp machines sharing a acess 2000 .mdb thats located on a SNAP server( simple network attached storage using a workgroup)

The setup has functioned perfectly for years but last year there was a microsoft update that messed it up.

Freshly installed xp systems have the same difficulty you speak of opening the .mdb file directly or from a shortcut.

They can however open the file just fine if you
1) start access first
2) open the .mdb file from inside access.

I've tried the internet exporer stuff and even went so far as to create a signed certificate project thing but have had no success.
Jun 1 '07 #11

P: 1
I had the same problem. 4 Vista machines and a shared Access 2000 database file that would only open on one machine at a time.

The solution:- http://support.microsoft.com/kb/935366

Phone Microsoft on 0870 60 10 100 with reference to Article ID :935366 (above)

They will email you the patch. Install it on all machines affected.

On the client machines you must open the Access program first then open the database file.

Works a treat for me with no sharing or rights issues.
Jul 4 '07 #12

P: 3
MICROSOFT FIX THIS SHARE .MDL SHORTCUT PROBLEM.

I have the same problem. 5 Vista machines and a shared Access 2000 database files that would only open on one machine at a time.

MS Longcuts - Unless You Do These Extra Steps: (It is a pain in the neck)
1) Start access first
2) open the .mdb file from inside access every time.
That means no Shortcuts only Longcuts.

NONE OF THESE BELOW WORK WHAT A JOKE:
I Tried This: MS Download Fix (http://support.microsoft.com/kb/935366)
I Tried This: Option 1 (http://allenbrowne.com/bug-17.html)

PS: On Another topic. Also Sendkeys command doesn't work in MS Access Visual Basic.
Oct 4 '07 #13

P: 1
got this from another web, it worked for me, damn pesky IE7 junk

Click on the Start menu, and open the Control Panel.

Open Add or Remove Programs.

On the left, click on Add/Remove Windows Components.

Uncheck Internet Explorer Enhanced Security Configuration.
Jan 30 '08 #14

Post your reply

Sign in to post your reply or Sign up for a free account.