473,231 Members | 2,587 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,231 software developers and data experts.

This Recordset is not updatable

Hi,

I am upgrading the current ms access .mdb file to a .adp with sql server back end.

I have been converted tables, forms, reports to .adp..
The tables are reflected at the server.

a)

I am unable to edit or add any records from the forms, when the data is viewable from sql server connection.

The error that's displayed on the status bar is "This recordset is not updatable"..

The file is working fine in .mdb mode.. The tables are directly editable in the sql server.. But thro forms I am unable to edit..

I checked the form properties in the "data tab"..

The "recordset type" is set to "updatable snapshot". (There are only 2 options in this property 1. snapshot 2. updatable snapshot)

"Allow Edits" Property is set to "Yes"
"Allow Deletions" Property is set to "Yes"
"Allow Additions" Property is set to "Yes"

"Data Entry" Property is set to "No" (If I set to yes I see a blank form when I run..)

Pls advice on how to get the forms working with sql server backend. Where should I change the recordset, if I have to do that, when all the above property looks fine..


b) The second problem I have is I am unable to Import the queries from .mdb to .adp.

If Stored Procedure the only way.. I have calculated fields which I am using it in the .mdb file. I am directly assigning to the "controlsource" property to the respective fields were I choose the queries for record source.. How do I do this with .adp?

If I do a import from sql server thro DTS , the .mdb queries are converted to tables and the calculated fields are not recognized, hence displaying "invalid column".

Kindly advice...

Thanks & Regards,
Ruth.
Mar 6 '07 #1
3 5213
MMcCarthy
14,534 Expert Mod 8TB
Ruth

At a guess I would say this is a SQL Server problem and has to do with the permissions that have been set up as in INSERT, UPDATE and DELETE permissions on the tables.

Mary
Mar 6 '07 #2
Ruth

At a guess I would say this is a SQL Server problem and has to do with the permissions that have been set up as in INSERT, UPDATE and DELETE permissions on the tables.

Mary

Thanks Ms. Mary..

Regards,
Ruth
Mar 7 '07 #3
MMcCarthy
14,534 Expert Mod 8TB
Thanks Ms. Mary..

Regards,
Ruth
No problems.
Mar 7 '07 #4

Sign in to post your reply or Sign up for a free account.

Similar topics

6
by: Henry Bloom | last post by:
Hello, I have two questions: 1. The file-size of my mdb-Database grew extremely large after having written a lot of VBA-code. I know about the /decompile-option tried it .... it did not work....
7
by: Martin Lacoste | last post by:
I have a very basic query that Access 2000 will not allow to be updatable. I've gone through all the situations in the help file where data cannot be updated, and I don't see that this query...
0
by: kentsoi | last post by:
i write the code as follow: when i try to edit text3's content' the message " this recordset is not updatable" is display. can anyone tell me what's wrong ??? thanks a lot...
3
by: Sim Zacks | last post by:
I have a postgresql backend with an access front end and I am trying to redefine the recordset of the form to use an ADO recordset. The problem is that the CursorType always changes to...
6
by: ZRexRider | last post by:
I've been reading the newsgroups and most of the solutions for this message are simple and obvious but unfortunately don't solve my problem. I have an MS-Access 2002 ADP application that...
9
by: Kosmos | last post by:
Hey guys...the following code doesn't seem to work refering to the line It says the field is not updatable...I've never updated a table from a module before so I'm not sure if I am doing this...
17
by: radio1 | last post by:
Configuration: Access 2002 and SQL Server 2000 using a .ADP Project. I would VERY MUCH appreciate anyone's input into this problem I'm having. I have a form in Access that does not permit...
1
by: Charlie | last post by:
What properties to you set to make a SQL 2005 recordset updatable? In Access, it's Recordset.edit Recordset!FieldName=SomeValue Recordset.update Any help is appreciated.
2
by: RZ15 | last post by:
Hi, A coworker of mine can not link or import tables into her Access database files, whether its from the server or from her own harddrive. When she tries, she is getting the message "Recordset is...
0
by: VivesProcSPL | last post by:
Obviously, one of the original purposes of SQL is to make data query processing easy. The language uses many English-like terms and syntax in an effort to make it easy to learn, particularly for...
3
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 3 Jan 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). For other local times, please check World Time Buddy In...
0
by: abbasky | last post by:
### Vandf component communication method one: data sharing ​ Vandf components can achieve data exchange through data sharing, state sharing, events, and other methods. Vandf's data exchange method...
0
by: fareedcanada | last post by:
Hello I am trying to split number on their count. suppose i have 121314151617 (12cnt) then number should be split like 12,13,14,15,16,17 and if 11314151617 (11cnt) then should be split like...
0
by: stefan129 | last post by:
Hey forum members, I'm exploring options for SSL certificates for multiple domains. Has anyone had experience with multi-domain SSL certificates? Any recommendations on reliable providers or specific...
0
Git
by: egorbl4 | last post by:
Скачал я git, хотел начать настройку, а там вылезло вот это Что это? Что мне с этим делать? ...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...
0
by: MeoLessi9 | last post by:
I have VirtualBox installed on Windows 11 and now I would like to install Kali on a virtual machine. However, on the official website, I see two options: "Installer images" and "Virtual machines"....
0
by: Aftab Ahmad | last post by:
So, I have written a code for a cmd called "Send WhatsApp Message" to open and send WhatsApp messaage. The code is given below. Dim IE As Object Set IE =...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.