By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,483 Members | 1,464 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,483 IT Pros & Developers. It's quick & easy.

Changing Data Type when importing Excel spreadsheet

P: n/a
Bad header on my first post. Sorry.
When I import a file using the Import Spreadsheet Wizard and I get to the
Field Options screen where it allows me to choose the fields and the Indexed
option, my Data Type option is grayed out. Shouldn't I be able to change
data types at that stage for each field as opposed to waiting until the data
is uploaded and changing in the table properties? Can someone tell me how to
turn that option on. Save a lot of time. Thanks

Mark
Feb 19 '07 #1
Share this Question
Share on Google+
4 Replies


P: n/a
This has been a problem with the Excel import wizard for years now.
Microsoft has fixed it in Access 2007, but the older versions still have the
problem.

The workaround I personally use is to create the table the way I want it
instead of using a Make Table query. Then attach the Excel, sheet, and use
Append query to populate it.

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Mark" <m.*******@snet.netwrote in message
news:PN*****************@newssvr19.news.prodigy.ne t...
Bad header on my first post. Sorry.
When I import a file using the Import Spreadsheet Wizard and I get to the
Field Options screen where it allows me to choose the fields and the
Indexed
option, my Data Type option is grayed out. Shouldn't I be able to change
data types at that stage for each field as opposed to waiting until the
data
is uploaded and changing in the table properties? Can someone tell me how
to
turn that option on. Save a lot of time. Thanks

Mark
Feb 20 '07 #2

P: n/a
Allen, so microsoft does not have a patch or hot fix for this for Access
2003?

Thanks
"Allen Browne" <Al*********@SeeSig.Invalidwrote in message
news:45***********************@per-qv1-newsreader-01.iinet.net.au...
This has been a problem with the Excel import wizard for years now.
Microsoft has fixed it in Access 2007, but the older versions still have
the problem.

The workaround I personally use is to create the table the way I want it
instead of using a Make Table query. Then attach the Excel, sheet, and use
Append query to populate it.

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Mark" <m.*******@snet.netwrote in message
news:PN*****************@newssvr19.news.prodigy.ne t...
>Bad header on my first post. Sorry.
When I import a file using the Import Spreadsheet Wizard and I get to the
Field Options screen where it allows me to choose the fields and the
Indexed
option, my Data Type option is grayed out. Shouldn't I be able to change
data types at that stage for each field as opposed to waiting until the
data
is uploaded and changing in the table properties? Can someone tell me how
to
turn that option on. Save a lot of time. Thanks

Mark

Feb 20 '07 #3

P: n/a
Interesting you should ask again, after Allen just wrote "but the older
versions still have the problem". Did you think that had changed between his
post and yours?

Larry

"Mark" <m.*******@snet.netwrote in message
news:km****************@newssvr23.news.prodigy.net ...
Allen, so microsoft does not have a patch or hot fix for this for Access
2003?

Thanks
"Allen Browne" <Al*********@SeeSig.Invalidwrote in message
news:45***********************@per-qv1-newsreader-01.iinet.net.au...
>This has been a problem with the Excel import wizard for years now.
Microsoft has fixed it in Access 2007, but the older versions still have
the problem.

The workaround I personally use is to create the table the way I want it
instead of using a Make Table query. Then attach the Excel, sheet, and
use Append query to populate it.

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Mark" <m.*******@snet.netwrote in message
news:PN*****************@newssvr19.news.prodigy.n et...
>>Bad header on my first post. Sorry.
When I import a file using the Import Spreadsheet Wizard and I get to
the
Field Options screen where it allows me to choose the fields and the
Indexed
option, my Data Type option is grayed out. Shouldn't I be able to change
data types at that stage for each field as opposed to waiting until the
data
is uploaded and changing in the table properties? Can someone tell me
how to
turn that option on. Save a lot of time. Thanks

Mark


Feb 20 '07 #4

P: n/a
Hey Larry, its time to move out of your parents basement.
"Larry Linson" <bo*****@localhost.notwrote in message
news:PsvCh.3053$Cr1.956@trnddc08...
Interesting you should ask again, after Allen just wrote "but the older
versions still have the problem". Did you think that had changed between
his post and yours?

Larry

"Mark" <m.*******@snet.netwrote in message
news:km****************@newssvr23.news.prodigy.net ...
>Allen, so microsoft does not have a patch or hot fix for this for Access
2003?

Thanks
"Allen Browne" <Al*********@SeeSig.Invalidwrote in message
news:45***********************@per-qv1-newsreader-01.iinet.net.au...
>>This has been a problem with the Excel import wizard for years now.
Microsoft has fixed it in Access 2007, but the older versions still have
the problem.

The workaround I personally use is to create the table the way I want it
instead of using a Make Table query. Then attach the Excel, sheet, and
use Append query to populate it.

--
Allen Browne - Microsoft MVP. Perth, Western Australia
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

"Mark" <m.*******@snet.netwrote in message
news:PN*****************@newssvr19.news.prodigy. net...
Bad header on my first post. Sorry.
When I import a file using the Import Spreadsheet Wizard and I get to
the
Field Options screen where it allows me to choose the fields and the
Indexed
option, my Data Type option is grayed out. Shouldn't I be able to
change
data types at that stage for each field as opposed to waiting until the
data
is uploaded and changing in the table properties? Can someone tell me
how to
turn that option on. Save a lot of time. Thanks

Mark



Feb 20 '07 #5

This discussion thread is closed

Replies have been disabled for this discussion.