By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,061 Members | 1,563 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,061 IT Pros & Developers. It's quick & easy.

Access Record Locking

P: 6
One more question for today! I have a database my whole department is using to store records. I want only one user to access the database at a time. Or, I at least want to make sure records are secured when a user is in the database. I have had issues where people have saved records - yet they are not in the database! I suspect it is due to multiple users entering records at the same time. I am not using any security settings - they tend not to work over our network, but I do have edit and delete access hidden so all users are able to do is to add records.

I have tested whether or not another employee can enter the database when I'm in it - and they are able to - how do I prevent this?

Please help!

Thanks,
Tania
[Email removed]
Feb 15 '07 #1
Share this Question
Share on Google+
5 Replies


MMcCarthy
Expert Mod 10K+
P: 14,534
In Tools - Options - Advanced ...Set Default Record Locking to Edited Record this will lock the record being edited (or all Records if you want to lock the database).

Mary
Feb 15 '07 #2

ADezii
Expert 5K+
P: 8,638
One more question for today! I have a database my whole department is using to store records. I want only one user to access the database at a time. Or, I at least want to make sure records are secured when a user is in the database. I have had issues where people have saved records - yet they are not in the database! I suspect it is due to multiple users entering records at the same time. I am not using any security settings - they tend not to work over our network, but I do have edit and delete access hidden so all users are able to do is to add records.

I have tested whether or not another employee can enter the database when I'm in it - and they are able to - how do I prevent this?

Please help!

Thanks,
Tania
[Email removed]
If you want only 1 User at a time to access your Database: Tools ==> Options ==> Advanced ==> Default open mode = Exclusive
Feb 16 '07 #3

NeoPa
Expert Mod 15k+
P: 31,494
I think Mary's response meant to say 'the whole Table' rather than 'the whole database'. That would probably be overkill.
Interesting point nevertheless :)
Feb 16 '07 #4

P: 6
Thank you so much for your help!! I found my error. I had the default open mode set to exclusive and the default record locking set to all records... I also had the open databases using record-level locking checked. Removing the record-level locking, it now does what I want... It does not allow me to access the table at all when another user is in it, and I get the appropriate Access message stating another user is in it.
Feb 16 '07 #5

NeoPa
Expert Mod 15k+
P: 31,494
Good for you Tania.
We're pleased you found your answer :)
Feb 16 '07 #6

Post your reply

Sign in to post your reply or Sign up for a free account.