467,169 Members | 996 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,169 developers. It's quick & easy.

Form Flashes Unexpectedly - Cannot Figure Out Cause

Hello Everyone,

I have a form in a multi-user database that flashes when the form is
opened. This is a failr involved form that contains header
information along with a continous subform. Below are a few details
of the issue that I think might be relavent.

- I am using Access 2003
- This only occurs on certain user's computers
- The code has finished running and the screens still flashes
- There are no on timer events on the form
- The recordcounts in the header do not populate while the form
is flashing
- If the user minimizes the form then maximizes it the flashing
stops and the record counts populate
- One of the users has plenty (1.2G) of RAM which is more than I
have on my machine that does NOT flash
- If the user uses any of the automated controls on the form
while it is flashing the application freezes
I have never seen this before in access and I cannot seem to figure
out why it is happening. Does anyone have any suggestions?

Thanks,
Dave

Feb 9 '07 #1
  • viewed: 2375
Share:
3 Replies
Dave S wrote:
Hello Everyone,

I have a form in a multi-user database that flashes when the form is
opened. This is a failr involved form that contains header
information along with a continous subform. Below are a few details
of the issue that I think might be relavent.

- I am using Access 2003
- This only occurs on certain user's computers
- The code has finished running and the screens still flashes
- There are no on timer events on the form
- The recordcounts in the header do not populate while the form
is flashing
- If the user minimizes the form then maximizes it the flashing
stops and the record counts populate
- One of the users has plenty (1.2G) of RAM which is more than I
have on my machine that does NOT flash
- If the user uses any of the automated controls on the form
while it is flashing the application freezes
I have never seen this before in access and I cannot seem to figure
out why it is happening. Does anyone have any suggestions?

Thanks,
Dave
Just a guess. If you have code in the OnCurrent and OnActivate, put
something in the code like
msgbox "Current"
and
msgbox "Activate"
and see how many times these events get called. It's possible that you
are setting filters or sorts or new row/recordsources that re-executes
the OnCurrent code multiple times.
Feb 9 '07 #2
On Feb 9, 12:09 pm, salad <o...@vinegar.comwrote:
Dave S wrote:
Hello Everyone,
I have a form in a multi-user database that flashes when the form is
opened. This is a failr involved form that contains header
information along with a continous subform. Below are a few details
of the issue that I think might be relavent.
- I am using Access 2003
- This only occurs on certain user's computers
- The code has finished running and the screens still flashes
- There are no on timer events on the form
- The recordcounts in the header do not populate while the form
is flashing
- If the user minimizes the form then maximizes it the flashing
stops and the record counts populate
- One of the users has plenty (1.2G) of RAM which is more than I
have on my machine that does NOT flash
- If the user uses any of the automated controls on the form
while it is flashing the application freezes
I have never seen this before in access and I cannot seem to figure
out why it is happening. Does anyone have any suggestions?
Thanks,
Dave

Just a guess. If you have code in the OnCurrent and OnActivate, put
something in the code like
msgbox "Current"
and
msgbox "Activate"
and see how many times these events get called. It's possible that you
are setting filters or sorts or new row/recordsources that re-executes
the OnCurrent code multiple times.- Hide quoted text -

- Show quoted text -
I have put stops in the code and followed it through to completion and
the form still flashes after all code has finished executing. I alos
tried your suggestion and I have no OnActivate code and the OnCurrent
event only occured once. One thing I forgot to mention above is that
the form open with the subform invisible. The subform only becomes
visible after the user makes a selection from a combo box in the
header which then tells the subform what set of data to display. It
is when the user makes a new selection from the combo box that the
flashing of the subform occurs.

Thanks,
Dave

Feb 9 '07 #3
Dave S wrote:
On Feb 9, 12:09 pm, salad <o...@vinegar.comwrote:
>>Dave S wrote:
>>>Hello Everyone,
>>>I have a form in a multi-user database that flashes when the form is
opened. This is a failr involved form that contains header
information along with a continous subform. Below are a few details
of the issue that I think might be relavent.
>> - I am using Access 2003
- This only occurs on certain user's computers
- The code has finished running and the screens still flashes
- There are no on timer events on the form
- The recordcounts in the header do not populate while the form
is flashing
- If the user minimizes the form then maximizes it the flashing
stops and the record counts populate
- One of the users has plenty (1.2G) of RAM which is more than I
have on my machine that does NOT flash
- If the user uses any of the automated controls on the form
while it is flashing the application freezes
>>>I have never seen this before in access and I cannot seem to figure
out why it is happening. Does anyone have any suggestions?
>>>Thanks,
Dave

Just a guess. If you have code in the OnCurrent and OnActivate, put
something in the code like
msgbox "Current"
and
msgbox "Activate"
and see how many times these events get called. It's possible that you
are setting filters or sorts or new row/recordsources that re-executes
the OnCurrent code multiple times.- Hide quoted text -

- Show quoted text -


I have put stops in the code and followed it through to completion and
the form still flashes after all code has finished executing. I alos
tried your suggestion and I have no OnActivate code and the OnCurrent
event only occured once. One thing I forgot to mention above is that
the form open with the subform invisible. The subform only becomes
visible after the user makes a selection from a combo box in the
header which then tells the subform what set of data to display. It
is when the user makes a new selection from the combo box that the
flashing of the subform occurs.

Thanks,
Dave
I was wondering if you had a subform.

Which form flashes; main, subform, or both?

What happens if you make a copy of the form and cut out the subform from
the copy? Is their flashing in the main form?

Do you have an OnCurrent event in the subform? Try the msgbox thing
there too.

Are you setting anything with
Me.Filter
Me.OrderBy
statments?

Make a copy and start snipping away code procedures. Maybe something
there is activating something.


Feb 9 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Graham Siener | last post: by
2 posts views Thread by Matt Sollars | last post: by
2 posts views Thread by John A Grandy | last post: by
4 posts views Thread by phancey@2bytes.co.uk | last post: by
3 posts views Thread by Ramesh Dodamani | last post: by
3 posts views Thread by Johnson | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.