471,355 Members | 1,794 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 471,355 software developers and data experts.

Export routine changes date format

Hi

I am having trouble with the transfertext acexportdelim function.

I have written several routines that export queries with date fields. I
have put format statements in the download queries as so that the data
is exported as dd/mm/yy.

Every time i run this it exports the dates as dd/mm/yy nn:hh:ss i
really don't understand why.

I built a brand new database with one table called Dates, and one field
named Birthdays

I created an export spec for this table and a qry in which i wrote the
following syntax

Birthdays: format([Dates].[Birthdays],"dd/mm/yy")

I then put one record in the table, ran the export and low and behold
the export still reads 01/01/01 00:00:00

I really don't understand how this is happening.

Thanks for any help in advance.

Gillian

Jan 26 '07 #1
1 1751
On 26 Jan 2007 08:54:45 -0800, "Gilz" <gd*****@tlpsystems.co.uk>
wrote:

It's simple once you realize that there is a difference between a date
VALUE and a date FORMAT.
The value of a variable of type Date is always an 8-byte entity that
includes seconds. How you format that, is entirely up to you. Your
viewer will also have a particular format built-in, so it may display
seconds. Not to worry, in your forms or reports you can still format
exactly the way you like.

-Tom.

>Hi

I am having trouble with the transfertext acexportdelim function.

I have written several routines that export queries with date fields. I
have put format statements in the download queries as so that the data
is exported as dd/mm/yy.

Every time i run this it exports the dates as dd/mm/yy nn:hh:ss i
really don't understand why.

I built a brand new database with one table called Dates, and one field
named Birthdays

I created an export spec for this table and a qry in which i wrote the
following syntax

Birthdays: format([Dates].[Birthdays],"dd/mm/yy")

I then put one record in the table, ran the export and low and behold
the export still reads 01/01/01 00:00:00

I really don't understand how this is happening.

Thanks for any help in advance.

Gillian
Jan 28 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Jay | last post: by
2 posts views Thread by jpr | last post: by
OuTCasT
2 posts views Thread by OuTCasT | last post: by
reply views Thread by XIAOLAOHU | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.