By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,395 Members | 2,505 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,395 IT Pros & Developers. It's quick & easy.

Report Containing Subreports Generates An Extra Blank Page

P: n/a
I have a report containing 2 subreports. The subreports each contain a
chart. The whole thing easily fits on one page but a second blank page
is consistently being generated.

This has nothing to do with the page width being too large because it
isn't, and the second blank page displays the report header and footer.
I can reduce the depth of the subreports so that they only take up one
half of the first page's depth, but the second blank page complete with
header and footer is still being produced.

If I remove the bottom subreport the problem disappears dispite the
fact that there is more that enough room on the first page to
accomodate the content.

Does anyone have any ideas as to what could possibly be causing this
behaviour? I've tried everything that I can think of without success.

Jan 25 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
I have had this problem when using the wizard? Anyway it was almost
always a result of the workspace being just a little to wide (I know
it's actually fine) so just drag the right edge of your workspace over
to the left a little bit, click to view the report and then go back to
the design view, you will notice it moved the border back. Now your
blank page should be gone.

On Jan 25, 12:16 pm, "Wayne" <cqdigi...@volcanomail.comwrote:
I have a report containing 2 subreports. The subreports each contain a
chart. The whole thing easily fits on one page but a second blank page
is consistently being generated.

This has nothing to do with the page width being too large because it
isn't, and the second blank page displays the report header and footer.
I can reduce the depth of the subreports so that they only take up one
half of the first page's depth, but the second blank page complete with
header and footer is still being produced.

If I remove the bottom subreport the problem disappears dispite the
fact that there is more that enough room on the first page to
accomodate the content.

Does anyone have any ideas as to what could possibly be causing this
behaviour? I've tried everything that I can think of without success.
Jan 25 '07 #2

P: n/a
Thanks for the reply, but this is not the problem. When the workspace
is too wide the extra page is generally blank. Mine contains the
header and footer. Besides this, if I remove the bottom subreport the
extra page disappears.

Jan 25 '07 #3

P: n/a
Can I suggest you check the width/height of the subreport and its placement
on the main report. Make sure the height of the subreport is small and "can
grow"
"Wayne" <cq*******@volcanomail.comwrote in message
news:11*********************@a34g2000cwb.googlegro ups.com...
Thanks for the reply, but this is not the problem. When the workspace
is too wide the extra page is generally blank. Mine contains the
header and footer. Besides this, if I remove the bottom subreport the
extra page disappears.

Jan 29 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.