By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,136 Members | 1,089 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,136 IT Pros & Developers. It's quick & easy.

Access controls appear disabled on record change

P: n/a
I have an Access form with some combo boxes in the Form Header that are
enabled/disabled using conditional formatting based on the setting in a
checkbox also in the Header (Combo box = Enabled by default; when
Checkbox = False, Combo Box = Disabled.).

When I open the form, the combo boxes are behaving as expected, and
when I change records (using the standard arrow buttons at the bottom
of the form) to a record with a different setting in that checkbox, the
combo boxes continue to behave as expected. But when I change to yet
another record, with the original setting for the checkbox, the combo
boxes appear to be somewhat in that second state of enablement, rather
than reverting back to the original state. So for example:

Record 1: Checkbox selected, combo boxes enabled as expected
Record 2: Checkbox de-selected, combo boxes disabled as expected
Record 3: Checkbox selected, combo boxes APPEAR partially disabled
(gray label and gray drop down arrow), but the user can click on them
and make a new selection.

My question is: Is there something I can do to ensure that on
scrolling to Record 3 that the text and the drop down arrow return to
black to indicate that the combo boxes are truly enabled?

Thanks in advance!

Jan 8 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.