By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,294 Members | 2,588 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,294 IT Pros & Developers. It's quick & easy.

linking subreports to the main report!

P: 9
Access 2003.

I have generated multiple crosstabs from the same main table. (I have multiple value fields) Then each of these crosstabs is created into a report. I am trying to combine all these reports into 1 main report. I used one of these crosstabs - report as the base, then started dragging in all of the reports into the detail section of the report. I then linked all the reports (subreports) by the CustomerID.

Then I ran the report, but i got the message:

"You can’t use a pass-through query or a non-fixed-column crosstab query as a record source for a subform or subreport. Before you bind the subform or subreport to a crosstab query, set the query’s ColumnHeadings property. "

Anyone know how to solve this problem?

Thanks in advance.
Dec 28 '06 #1
Share this Question
Share on Google+
2 Replies


NeoPa
Expert Mod 15k+
P: 31,494
I can't imagine there is a solution.
How do you go about designing a report when you can't predict how many columns it will need?
Am I missing something?
Dec 30 '06 #2

MMcCarthy
Expert Mod 10K+
P: 14,534
Access 2003.

I have generated multiple crosstabs from the same main table. (I have multiple value fields) Then each of these crosstabs is created into a report. I am trying to combine all these reports into 1 main report. I used one of these crosstabs - report as the base, then started dragging in all of the reports into the detail section of the report. I then linked all the reports (subreports) by the CustomerID.

Then I ran the report, but i got the message:

"You can’t use a pass-through query or a non-fixed-column crosstab query as a record source for a subform or subreport. Before you bind the subform or subreport to a crosstab query, set the query’s ColumnHeadings property. "

Anyone know how to solve this problem?

Thanks in advance.
I'm not sure what you've done but check that all the subreports opens on its own correctly then check that the main report opens on it's own with no subreports.

Are any or all of these reports giving you problems individually?

Mary
Jan 1 '07 #3

Post your reply

Sign in to post your reply or Sign up for a free account.