By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,640 Members | 2,118 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,640 IT Pros & Developers. It's quick & easy.

Columns Show on Design Grid But Not on Data Sheet -- Access 2003

P: n/a
I encountered this problem for the first time today while trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet, even
though the box is checked. I've already done some trouble shooting,
making sure the box is checked, making sure that the columns aren't
hidden.

Also, I went to the toolbar menu, under tools and then options, and
checked the box to display all columns. (That should make ALL the
columns appear in data sheet as if you did a SELECT * statement from
the table, shouldn't it?) I also double checked the SQL view, and the
necessary select statements for the new columns I want are there as a
result of my adding columns through the design grid.

Has anybody run into this before and fixed it? If so, thanks in
advance if you can give me a clue.

Mike

Dec 28 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi, Mike.
trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet
Since this is linked table, since the time you created the link, has anything
changed in the information saved in the link, such as path and file name,
permissions, table structure, et cetera? If you change anything on the back
end, drop the link and recreate it so that the changes will be reflected in the
linked table information in your Access database application.

HTH.
Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips and tutorials.
http://www.Access.QBuilt.com/html/ex...ributors2.html for contact info.
"Mike" <mg******@gmail.comwrote in message
news:11**********************@a3g2000cwd.googlegro ups.com...
>I encountered this problem for the first time today while trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet, even
though the box is checked. I've already done some trouble shooting,
making sure the box is checked, making sure that the columns aren't
hidden.

Also, I went to the toolbar menu, under tools and then options, and
checked the box to display all columns. (That should make ALL the
columns appear in data sheet as if you did a SELECT * statement from
the table, shouldn't it?) I also double checked the SQL view, and the
necessary select statements for the new columns I want are there as a
result of my adding columns through the design grid.

Has anybody run into this before and fixed it? If so, thanks in
advance if you can give me a clue.

Mike

Dec 28 '06 #2

P: n/a
Are you suing a form/subform to view the linked DBASE table?

If you are, adding the items to the query will not make them show up on
the subform, they have to be added to the form also.

Just a thought....

Ron

Dec 28 '06 #3

P: n/a
This one's solved. I thought I troubleshot all the possible causes,
but I'm kind of embarrassed. I didn't look close enough in the data
sheet view. I didn't expect the new columns to show up in the same
place until I went to the data sheet and drug them to where I wanted
them, but they were there, all along. I just needed to look closer.

'69 Camaro wrote:
Hi, Mike.
trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet

Since this is linked table, since the time you created the link, has anything
changed in the information saved in the link, such as path and file name,
permissions, table structure, et cetera? If you change anything on the back
end, drop the link and recreate it so that the changes will be reflected in the
linked table information in your Access database application.

HTH.
Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips and tutorials.
http://www.Access.QBuilt.com/html/ex...ributors2.html for contact info.
"Mike" <mg******@gmail.comwrote in message
news:11**********************@a3g2000cwd.googlegro ups.com...
I encountered this problem for the first time today while trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet, even
though the box is checked. I've already done some trouble shooting,
making sure the box is checked, making sure that the columns aren't
hidden.

Also, I went to the toolbar menu, under tools and then options, and
checked the box to display all columns. (That should make ALL the
columns appear in data sheet as if you did a SELECT * statement from
the table, shouldn't it?) I also double checked the SQL view, and the
necessary select statements for the new columns I want are there as a
result of my adding columns through the design grid.

Has anybody run into this before and fixed it? If so, thanks in
advance if you can give me a clue.

Mike
Dec 30 '06 #4

P: n/a
Hi, Mike.
This one's solved.
Excellent.
I thought I troubleshot all the possible causes,
but I'm kind of embarrassed.
.. . .
I just needed to look closer.
Don't be embarrassed. Folks reading this thread may have the same problem
later, and you can be sure they will look closer, too, because some things are
easy to miss the first time.

Have a Happy New Year!
Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips and tutorials.
http://www.Access.QBuilt.com/html/ex...ributors2.html for contact info.
"Mike" <mg******@gmail.comwrote in message
news:11*********************@a3g2000cwd.googlegrou ps.com...
This one's solved. I thought I troubleshot all the possible causes,
but I'm kind of embarrassed. I didn't look close enough in the data
sheet view. I didn't expect the new columns to show up in the same
place until I went to the data sheet and drug them to where I wanted
them, but they were there, all along. I just needed to look closer.

'69 Camaro wrote:
>Hi, Mike.
trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet

Since this is linked table, since the time you created the link, has anything
changed in the information saved in the link, such as path and file name,
permissions, table structure, et cetera? If you change anything on the back
end, drop the link and recreate it so that the changes will be reflected in
the
linked table information in your Access database application.

HTH.
Gunny

See http://www.QBuilt.com for all your database needs.
See http://www.Access.QBuilt.com for Microsoft Access tips and tutorials.
http://www.Access.QBuilt.com/html/ex...ributors2.html for contact info.
"Mike" <mg******@gmail.comwrote in message
news:11**********************@a3g2000cwd.googlegr oups.com...
>I encountered this problem for the first time today while trying to add
some columns to a query from a linked DBASEIII file. The new columns
that I added on the design grid do not show up on the data sheet, even
though the box is checked. I've already done some trouble shooting,
making sure the box is checked, making sure that the columns aren't
hidden.

Also, I went to the toolbar menu, under tools and then options, and
checked the box to display all columns. (That should make ALL the
columns appear in data sheet as if you did a SELECT * statement from
the table, shouldn't it?) I also double checked the SQL view, and the
necessary select statements for the new columns I want are there as a
result of my adding columns through the design grid.

Has anybody run into this before and fixed it? If so, thanks in
advance if you can give me a clue.

Mike

Dec 30 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.