By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,504 Members | 1,212 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,504 IT Pros & Developers. It's quick & easy.

Paste into Record causes record corruption then Invalid Argument on opening bound form

P: n/a
ian
One of my customers occasionally gets a corrupted record - where all
the fields show #error and forms bound to the damaged table do not open
(the VBA code doesn't execute) and the error message is Invalid
argument. Compact & repair doesn't repair the corrupted record, so I
have to rebuild the table.

This is happening every two or three months in a database which gets a
regular daily thrashing from three users and doesn't exhibit any other
problems.

Today I discovered that two recent occurrences have both occurred
immediately after they copied then pasted information into a field. I
know that they do this all the time - so the question is why is paste
sometimes causing a problem, but working normally all the rest of the
time. Todays problem was caused by copying information from a web page,
which isn't unusual. My guess is that they have somehow pasted some
information which Access can't understand and that corrupts the record.

Has anyone experienced similar problems after pasting data?

Has anyone found a solution to this problem?

Does anyone have any more knowledge on how the Windows copy/paste
function works so that I could somehow screen the pasted data?
Thanks in advance

Ian

Dec 12 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.