By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,163 Members | 944 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,163 IT Pros & Developers. It's quick & easy.

Report background image won't display...

P: 1
Hey all.

I've encountered a problem fore wich I need a litle help...

I have set a reference to a picture on my local disk in a Reports Picture property (I programmaticly set the reference in the Reports "Page" event procedure, because the reference is dynamic and changes with each record that is printed). In this case the argument (a number) is provided by the calling procedure in a Form object

Private Sub Report_Page()
Dim myOpenArgs As String
If Not IsNull(Me.OpenArgs) Then
myOpenArgs = Me.OpenArgs
Me.Picture = "\\Logidasrv2\fruits images\" & myOpenArgs & ".jpg"
End If
End Sub

The Report is displaying correctly, but without the background picture...???

If the report contains more than one record in the recordsource and i navigate to the next record, suddently the background picture is displayed as well
Nov 28 '06 #1
Share this Question
Share on Google+
1 Reply


NeoPa
Expert Mod 15k+
P: 31,660
Can you put this in the OnOpen event of the report rather than the OnPage event (which only executes for the first time when a page has been formatted (I think))?
Nov 28 '06 #2

Post your reply

Sign in to post your reply or Sign up for a free account.