By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,863 Members | 838 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,863 IT Pros & Developers. It's quick & easy.

Sub report

P: 6
i am using ms access 2003 & VBA .i have one main report and 3 sub reports embeddedd in the main report. if i am running teh subreport alone it is dispalying teh data.but if i am running teh main reoport all teh three subreports are not displaying any data? do i need to set anything programatically to dispaly it.and one more thing when i am running this main report it is asking for an unknown parameter .if i am cancellin g that pop up also main report is showing .how to avoid that?

Please let me kmow if anyone knows how to correct these 2 error.
Nov 7 '06 #1
Share this Question
Share on Google+
2 Replies


NeoPa
Expert Mod 15k+
P: 31,418
Try running the query that the report is based on and see if the unknown parameter comes up.
The unknown parameter is something you've asked it to use in the query which it doesn't recognise.
Nov 7 '06 #2

MMcCarthy
Expert Mod 10K+
P: 14,534
i am using ms access 2003 & VBA .i have one main report and 3 sub reports embeddedd in the main report. if i am running teh subreport alone it is dispalying teh data.but if i am running teh main reoport all teh three subreports are not displaying any data? do i need to set anything programatically to dispaly it.and one more thing when i am running this main report it is asking for an unknown parameter .if i am cancellin g that pop up also main report is showing .how to avoid that?

Please let me kmow if anyone knows how to correct these 2 error.
What is the common link between the subreports and the main report.

Have you set master/child links or are you using filters.
Nov 7 '06 #3

Post your reply

Sign in to post your reply or Sign up for a free account.