By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,480 Members | 763 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,480 IT Pros & Developers. It's quick & easy.

Restrict the number of records that print on a report

P: n/a
itm
I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!

Oct 26 '06 #1
Share this Question
Share on Google+
7 Replies


P: n/a
On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:
I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!
Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 26 '06 #2

P: n/a
itm
Thank you for providing excellent directions! I followed them however,
in my report, they did not produce the expected results. Is there
something else I need to do or check for? Your help is deeply
appreciated!

fredg wrote:
On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:
I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!

Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 27 '06 #3

P: n/a
On 27 Oct 2006 07:51:22 -0700, it*@itmservices.com wrote:
Thank you for providing excellent directions! I followed them however,
in my report, they did not produce the expected results. Is there
something else I need to do or check for? Your help is deeply
appreciated!

fredg wrote:
>On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:
>>I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!

Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
You're there with the database and I'm here far away.
What results did you get?
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 27 '06 #4

P: n/a
itm
Sorry. There was no change at all in the way the report ran. The
first page that would have more than 20 records in on page 35. It's
extra records print on the next page.

I sure appreciate you working with me to resolve this!
fredg wrote:
On 27 Oct 2006 07:51:22 -0700, it*@itmservices.com wrote:
Thank you for providing excellent directions! I followed them however,
in my report, they did not produce the expected results. Is there
something else I need to do or check for? Your help is deeply
appreciated!

fredg wrote:
On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:

I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!

Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail

You're there with the database and I'm here far away.
What results did you get?
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 27 '06 #5

P: n/a
On 27 Oct 2006 14:35:52 -0700, it*@itmservices.com wrote:
Sorry. There was no change at all in the way the report ran. The
first page that would have more than 20 records in on page 35. It's
extra records print on the next page.

I sure appreciate you working with me to resolve this!
fredg wrote:
>On 27 Oct 2006 07:51:22 -0700, it*@itmservices.com wrote:
>>Thank you for providing excellent directions! I followed them however,
in my report, they did not produce the expected results. Is there
something else I need to do or check for? Your help is deeply
appreciated!

fredg wrote:
On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:

I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?
>
Thanks so much for your help!

Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail

You're there with the database and I'm here far away.
What results did you get?
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Well, now I'm completely confused.
Your original post stated "I want to limit the number of accounts that
print on the first page to 20"
Now you state that the first page that has 'more' than 20 records is
page 35. Of course the code I gave you won't work, you're not on Page
1!
If it's always page 35 that has the more than 20 records, change the
code to reflect that. If there is some other criteria, then re-think
your question so that someone who is not there will understand it.
Re-write your question and re-post it.
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 27 '06 #6

P: n/a
itm
I'm sorry for the confusion. I did not mean that it is always any one
page that has more than 20 records.

It is one page letter. The bottom of the letter will list the accounts
for 1 owner. Some owners have more than 1 account. When I preview my
report with all owners, depending on the particular group of owners
selected, owners with more than 20 accounts could occur on page 1, then
not again until page 29. So it is not always on page 35 or always on
any particular page. It just happens that in the particular owner set
that I am working with right now, my first owner with more than 20
accounts is on the 35th page of the report in report preview. When I
initially referred to limiting the number of records on the first page
to 20, that was because the second page will have the remainder of the
accounts for that particular owner. (But I have to run the 2nd page
separately unless there is a way to include the second page in the
report to print if there are more than 20 records on the first page.)

Did I explain that any better?

Again, I apologize for the confusion and appreciate your patience!
Thanks for your help!

fredg wrote:
On 27 Oct 2006 14:35:52 -0700, it*@itmservices.com wrote:
Sorry. There was no change at all in the way the report ran. The
first page that would have more than 20 records in on page 35. It's
extra records print on the next page.

I sure appreciate you working with me to resolve this!
fredg wrote:
On 27 Oct 2006 07:51:22 -0700, it*@itmservices.com wrote:

Thank you for providing excellent directions! I followed them however,
in my report, they did not produce the expected results. Is there
something else I need to do or check for? Your help is deeply
appreciated!

fredg wrote:
On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:

I have a mail out to send to a group of owners with multiple accounts.
I want to limit the number of accounts that print on the first page to
20. I want remaining accounts to print on a second page. Is there a
way to accomplish this?

Thanks so much for your help!

Add an unbound control to the detail section.
Set it's Control source to
=1
Set it's Running Sum property to Over All
Name this control "RecCount"
You can make it not visible.

Add a page break control to the report detail section.

Code the Detail Format event:
PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail

You're there with the database and I'm here far away.
What results did you get?
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail

Well, now I'm completely confused.
Your original post stated "I want to limit the number of accounts that
print on the first page to 20"
Now you state that the first page that has 'more' than 20 records is
page 35. Of course the code I gave you won't work, you're not on Page
1!
If it's always page 35 that has the more than 20 records, change the
code to reflect that. If there is some other criteria, then re-think
your question so that someone who is not there will understand it.
Re-write your question and re-post it.
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 30 '06 #7

P: n/a
itm
Also, I just realized, the code you wrote is preventing more than 20
records from printing on the first page. I was misled because the rest
of the accounts are still printing on the top of the next record which
I didn't think would happen with the code. Please forgive me again!
Now, I either need a 2nd page in my report (which I am not sure is
possible) or I need the additional accounts (over 20) not to print on
the next record.

You are so appreciated, Fred!
it*@itmservices.com wrote:
I'm sorry for the confusion. I did not mean that it is always any one
page that has more than 20 records.

It is one page letter. The bottom of the letter will list the accounts
for 1 owner. Some owners have more than 1 account. When I preview my
report with all owners, depending on the particular group of owners
selected, owners with more than 20 accounts could occur on page 1, then
not again until page 29. So it is not always on page 35 or always on
any particular page. It just happens that in the particular owner set
that I am working with right now, my first owner with more than 20
accounts is on the 35th page of the report in report preview. When I
initially referred to limiting the number of records on the first page
to 20, that was because the second page will have the remainder of the
accounts for that particular owner. (But I have to run the 2nd page
separately unless there is a way to include the second page in the
report to print if there are more than 20 records on the first page.)

Did I explain that any better?

Again, I apologize for the confusion and appreciate your patience!
Thanks for your help!

fredg wrote:
On 27 Oct 2006 14:35:52 -0700, it*@itmservices.com wrote:
Sorry. There was no change at all in the way the report ran. The
first page that would have more than 20 records in on page 35. It's
extra records print on the next page.
>
I sure appreciate you working with me to resolve this!
fredg wrote:
>On 27 Oct 2006 07:51:22 -0700, it*@itmservices.com wrote:
>>
>>Thank you for providing excellent directions! I followed them however,
>>in my report, they did not produce the expected results. Is there
>>something else I need to do or check for? Your help is deeply
>>appreciated!
>>>
>>fredg wrote:
>>>On 26 Oct 2006 11:47:55 -0700, it*@itmservices.com wrote:
>>>>
>>>>I have a mail out to send to a group of owners with multiple accounts.
>>>>I want to limit the number of accounts that print on the first page to
>>>>20. I want remaining accounts to print on a second page. Is there a
>>>>way to accomplish this?
>>>>>
>>>>Thanks so much for your help!
>>>>
>>>Add an unbound control to the detail section.
>>>Set it's Control source to
>>>=1
>>>Set it's Running Sum property to Over All
>>>Name this control "RecCount"
>>>You can make it not visible.
>>>>
>>>Add a page break control to the report detail section.
>>>>
>>>Code the Detail Format event:
>>>PageBreakName.Visible = (Me.Page = 1 and Me![RecCount] = 20)
>>>--
>>>Fred
>>>Please respond only to this newsgroup.
>>>I do not reply to personal e-mail
>>
>You're there with the database and I'm here far away.
>What results did you get?
>--
>Fred
>Please respond only to this newsgroup.
>I do not reply to personal e-mail
Well, now I'm completely confused.
Your original post stated "I want to limit the number of accounts that
print on the first page to 20"
Now you state that the first page that has 'more' than 20 records is
page 35. Of course the code I gave you won't work, you're not on Page
1!
If it's always page 35 that has the more than 20 records, change the
code to reflect that. If there is some other criteria, then re-think
your question so that someone who is not there will understand it.
Re-write your question and re-post it.
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Oct 30 '06 #8

This discussion thread is closed

Replies have been disabled for this discussion.