By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
428,601 Members | 1,116 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 428,601 IT Pros & Developers. It's quick & easy.

Have form not navigate out of current form

P: n/a
I want to be able to keep the current form on the current record. That
is, the arrow key, the tab or the enter should not cause the form to go
to next record or previous record. Preferably loop from last tab stop
to first and visa versa.

Aug 17 '06 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Hi Deacon,

On the Form Property sheet there is a property called "Cycle". It is
the 36th property listing in the Form property sheet (make sure you are
on the Form property sheet because a textbox property sheet wont have
this property - only the Form property sheet - right-click on the little
black square on the left upper corner of the Form design view to access
the form property sheet). Go down 36 properties from the top of the
"All" tab on the form property sheet. There are 3 options here: All
Records, Current Record, Current Page. Select current record. Now you
can't tab out of that record. The only way to get to the next record is
by clicking on the Navigations buttons (or a custom button if you placed
one on the form).

Rich

*** Sent via Developersdex http://www.developersdex.com ***
Aug 17 '06 #2

P: n/a
On 17 Aug 2006 08:00:57 -0700, Deacon Dan wrote:
I want to be able to keep the current form on the current record. That
is, the arrow key, the tab or the enter should not cause the form to go
to next record or previous record. Preferably loop from last tab stop
to first and visa versa.
To keep the Tab and Enter key from moving to the next record, set the
Form's Cycle property to Current Record.
--
Fred
Please respond only to this newsgroup.
I do not reply to personal e-mail
Aug 17 '06 #3

P: n/a

Thanks to all repliers. Resetting the Cycle property got me exactly
what I wanted!

Aug 17 '06 #4

This discussion thread is closed

Replies have been disabled for this discussion.