By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,158 Members | 917 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,158 IT Pros & Developers. It's quick & easy.

Repost: Second Database Slow To Open

P: n/a
Original Post:

The following problem started on my PC about a week ago and I can't
link it to any specific change. I'm using Access XP.

If I have any database open and try to open any other database by
double clicking its file in Explorer, it takes about 5 seconds to open.

Previously the second database would open almost instantaneously, as
one would expect on a reasonably fast machine.
However if I have any database open and then open a second instance of
Access by running it from the Start menu it opens instantaneously. If
I then double click any another database file in Explorer it will use
the open instance of Access and open instantaneously.
I have tried uninstalling and then reinstalling Access but the problem
remains. If anyone can give me a clue as to what is causing the
problem, and better still how to fix it, I would appreciate it.

Original Post Ends Here.

Since posting this, because of this problem and a few others I have
reinstalled Windows and all my apps including Access 2002 SP3. The
above problem seemed to disappear for a short time but is now back
again. Upon closer investigation, I have found the following:

When I try to open the second database, Access opens immediately, it is
the process of loading the actual file that causes the delay.

The problem is only apparent with mdbs, not mdes.

If I create a shortcut to the mdb that includes the path to
msaccess.exe, the file opens immediately without delay.

Obviously the file association for mdbs is msaccess.exe or they
wouldn't open at all. What I can't understand is why including the
path to msaccess.exe in a shortcut to the file resolves the problem.

Any help or comment is appreciated.

Jul 29 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.