By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,985 Members | 2,907 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,985 IT Pros & Developers. It's quick & easy.

quer files don't work with back-end database

P: n/a
Goal: : To improve an application's performance by basing sub forms and
combo

The application has a front and back-end. There is no SQL server
involved. I use a module for, seeking out the back-end and automatically
linking to the back-end in order that I might be able to provide
updates. This has worked for me since first setting everything up.

First let me define what I mean by, “sub form” as to how I am designing
my application. I have a number of, what I call, “main (unbound) forms”
that are used to open up separate application modules. Each module
contains a number of hyperlinks to each of the other application
modules. Also, each main form (application module) contains a tab form
with bound forms. Therefore, I am calling these lower level bound forms,
sub forms and basing them on query files instead of tables. Many of the
tables have fields for collecting information across a second form. I
did not want to bring back all the fields when they are used in any of
the two are three forms bound with the same table.

Problem: When I base either a main form or a sub-form on a query, that
particular front-end query form no longer links to the back-end database
table via a query file whenever I import everything g into a new/fresh
version of the front-end application. Whnever I open one of the query
files via the form, I get an error message in each of the fields
indicating it can't fine the field even though the table is listed with
all the fields. No, I do not have the same problem with forms based on
tables.

I suspect that my problem is in what I am calling a main and sub form;
and that the main form is really the first level bound form and never
the top unbound form if one is used. I have a lot of forms. I just
wanted to get some feedback on
my suspicions or find out what else could be the source of my problem
before re-doing everything.

Thanks,
John

*** Sent via Developersdex http://www.developersdex.com ***
May 18 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.