By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,493 Members | 1,351 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,493 IT Pros & Developers. It's quick & easy.

how to use decompile on secured db

P: n/a
Jan
Hi:

I've used the /decompile switch lots of times when working with
troublesome databases. Now, though, I have a database that is secured,
and I can't get the /decompile switch to work with the /wrkgrp switch.

Here's the shortcut I usually use for starting the secured database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

Normally if I were running decompile on the same db but with no security
I'd call it as such:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /decompile

I tried combining the switches in just about every manner I could think
of, but it never actually ran the decompile.

I also tried switching workgroups using the wrkgrp administrator and
then running decompile but it also didn't work

What's the proper syntax for doing this?

Thanks.

Jan
May 8 '06 #1
Share this Question
Share on Google+
13 Replies


P: n/a
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:
I also tried switching workgroups using the wrkgrp administrator
and then running decompile but it also didn't work


What didn't work? Did you get the appropriate logon? Or did you get
a permissions error? Or did you get no decompile?

That is, which part is failing, the workgroup part or the decompile
part?

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
May 8 '06 #2

P: n/a
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:
Here's the shortcut I usually use for starting the secured
database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"


Try creating a shortcut with this command line:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
/wrkgrp "c:\stempelc\area\hacla\systemHACLA.mdw" /decompile

Note that you don't have to specify the name of the file you are
opening -- Access will prompt you for that.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
May 8 '06 #3

P: n/a
Just use
"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

and add the /decompile
Works IME

So it would become:
"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"
/decompile

PathToMsAccess <space> PathToMdb <space> /wrkgrp <space> PathToWrkgrpFile <space> /decompile

Arno R
"Jan" <ja*@stempelconsulting.com> schreef in bericht news:12*************@corp.supernews.com...
Hi:

I've used the /decompile switch lots of times when working with
troublesome databases. Now, though, I have a database that is secured,
and I can't get the /decompile switch to work with the /wrkgrp switch.

Here's the shortcut I usually use for starting the secured database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

Normally if I were running decompile on the same db but with no security
I'd call it as such:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /decompile

I tried combining the switches in just about every manner I could think
of, but it never actually ran the decompile.

I also tried switching workgroups using the wrkgrp administrator and
then running decompile but it also didn't work

What's the proper syntax for doing this?

Thanks.

Jan

May 8 '06 #4

P: n/a
Jan
Hi, David:

When I use your solution it opens access, doesn't prompt for a password,
and then won't open the db (when I go to do it manually) because it says
I don't have the permissions
for the db (of course not; it thinks I'm admin!)

Any thoughts?

Jan

David W. Fenton wrote:
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:

Here's the shortcut I usually use for starting the secured
database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

Try creating a shortcut with this command line:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw" /decompile

Note that you don't have to specify the name of the file you are
opening -- Access will prompt you for that.

May 9 '06 #5

P: n/a
Jan
Hi, Arno:

Thanks for the suggestion. When I do it, it opens the database like
normal but I don't get that message that I usually get on decompile
(Microsoft has converted the code to the current version of Visual Basic...)
I assume from this that it didn't really decompile.

Jan

Arno R wrote:
Just use "C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

and add the /decompile Works IME

So it would become: "C:\Program Files\Microsoft
OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw" /decompile

PathToMsAccess <space> PathToMdb <space> /wrkgrp <space>
PathToWrkgrpFile <space> /decompile

Arno R
"Jan" <ja*@stempelconsulting.com> schreef in bericht
news:12*************@corp.supernews.com...
Hi:

I've used the /decompile switch lots of times when working with
troublesome databases. Now, though, I have a database that is
secured, and I can't get the /decompile switch to work with the
/wrkgrp switch.

Here's the shortcut I usually use for starting the secured
database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"

Normally if I were running decompile on the same db but with no
security I'd call it as such:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /decompile

I tried combining the switches in just about every manner I could
think of, but it never actually ran the decompile.

I also tried switching workgroups using the wrkgrp administrator
and then running decompile but it also didn't work

What's the proper syntax for doing this?

Thanks.

Jan

May 9 '06 #6

P: n/a
Jan
What generally happens, if the whole thing goes through, is that I get
the db to open but I don't get that usual decompile message about how
Microsoft has converted the code to the current version of Visual Basic.
From that I assume that it didn't really decompile.

David W. Fenton wrote:
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:

I also tried switching workgroups using the wrkgrp administrator
and then running decompile but it also didn't work

What didn't work? Did you get the appropriate logon? Or did you get a
permissions error? Or did you get no decompile?

That is, which part is failing, the workgroup part or the decompile
part?

May 9 '06 #7

P: n/a
"Jan" <ja*@stempelconsulting.com> schreef in bericht news:12*************@corp.supernews.com...
Hi, David:

When I use your solution it opens access, doesn't prompt for a password,
and then won't open the db (when I go to do it manually) because it says
I don't have the permissions
for the db (of course not; it thinks I'm admin!)

Any thoughts?

Jan

David W. Fenton wrote:
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:

Here's the shortcut I usually use for starting the secured
database:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE"
"c:\stempelc\area\hacla\haclasecurenew.mdb" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw"



Try creating a shortcut with this command line:

"C:\Program Files\Microsoft OfficeXP\Office10\MSACCESS.EXE" /wrkgrp
"c:\stempelc\area\hacla\systemHACLA.mdw" /decompile

Note that you don't have to specify the name of the file you are
opening -- Access will prompt you for that.


If you used David's idea and it works the way you describe I guess you made a typo in the PathToWorgroupFile

Arno R
May 10 '06 #8

P: n/a

"Jan" <ja*@stempelconsulting.com> schreef in bericht news:12*************@corp.supernews.com...
Hi, Arno:

Thanks for the suggestion. When I do it, it opens the database like
normal but I don't get that message that I usually get on decompile
(Microsoft has converted the code to the current version of Visual Basic...)
I assume from this that it didn't really decompile.



The message you are decribing was a A97 message.
I do not see this message anymore when I work with A2k or newer.

Try: MsgBox "CompileStatus: " & Application.IsCompiled

Arno R
May 10 '06 #9

P: n/a
Jan
Hi, Arno:

Wow! I do so much work in A97 that I never realized it was different in
A2K etc. I've decompiled XP apps before but never paid much attention
to the lack of message.

So if iscompiled comes out false then it worked? Learn something new
every day.

Thanks a bunch.

Jan

Arno R wrote:
"Jan" <ja*@stempelconsulting.com> schreef in bericht
news:12*************@corp.supernews.com...
Hi, Arno:

Thanks for the suggestion. When I do it, it opens the database
like normal but I don't get that message that I usually get on
decompile (Microsoft has converted the code to the current version
of Visual Basic...) I assume from this that it didn't really
decompile.


The message you are decribing was a A97 message. I do not see this
message anymore when I work with A2k or newer.

Try: MsgBox "CompileStatus: " & Application.IsCompiled

Arno R

May 10 '06 #10

P: n/a

See http://trigeminal.com/usenet/usenet004.asp for more info on decompile (even in Dutch!)

Arno R
"Jan" <ja*@stempelconsulting.com> schreef in bericht news:12*************@corp.supernews.com...
Hi, Arno:

Wow! I do so much work in A97 that I never realized it was different in
A2K etc. I've decompiled XP apps before but never paid much attention
to the lack of message.

So if iscompiled comes out false then it worked? Learn something new
every day.

Thanks a bunch.

Jan

Arno R wrote:
"Jan" <ja*@stempelconsulting.com> schreef in bericht
news:12*************@corp.supernews.com...
Hi, Arno:

Thanks for the suggestion. When I do it, it opens the database
like normal but I don't get that message that I usually get on
decompile (Microsoft has converted the code to the current version
of Visual Basic...) I assume from this that it didn't really
decompile.




The message you are decribing was a A97 message. I do not see this
message anymore when I work with A2k or newer.

Try: MsgBox "CompileStatus: " & Application.IsCompiled

Arno R

May 10 '06 #11

P: n/a
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:
When I use your solution it opens access, doesn't prompt for a
password, and then won't open the db (when I go to do it manually)
because it says I don't have the permissions
for the db (of course not; it thinks I'm admin!)


Does the admin account in your specified MDW file have a password on
it? If not, then you have to supply the user argument in the command
line to force the logon prompt.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
May 10 '06 #12

P: n/a
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:
What generally happens, if the whole thing goes through, is that I
get the db to open but I don't get that usual decompile message
about how Microsoft has converted the code to the current version
of Visual Basic.
From that I assume that it didn't really decompile.


I A2K and later, there is no such message -- that only happens in
A97.

You can test it by compiling the database before your attempted
decompile, and then checking to see if the code is uncompiled (if
it's still compiled, the menu items for compiling will be disabled).

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
May 10 '06 #13

P: n/a
Jan <ja*@stempelconsulting.com> wrote in
news:12*************@corp.supernews.com:
Learn something new
every day.


I learned something, too -- I'd never known about the .IsCompiled
property. Seems to me it's attached to the wrong object, though, as
it isn't really a property of the Access application, but of your
MDB.

And the property also exists in A97.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
May 10 '06 #14

This discussion thread is closed

Replies have been disabled for this discussion.