By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,476 Members | 1,529 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,476 IT Pros & Developers. It's quick & easy.

Forms freezing

P: n/a
Pat
I'm having some problems with forms freezing up on me.

I have a front end linked to tables in 2 back ends. Users can open a form
(quotes) which is linked to
a table in be1. while adding a record to this form, the user can open a
form (stations) linked to a table in be2 which will generate a price, text
etc and insert info back into first form (quotes). This works.

The problem is that every so often the user opens the 2nd form in order to
update (change something)
and when he closes it, the 1st form freezes. - all the code runs, the info
on the first form is updated,
no error is generated, but the program is just frozen. you have to close it
(through taskmaster) and restart again in order to get access again.

Could the 2 different back ends be causing this. Does linking to different
be's from the same front end
cause issues?
Apr 26 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Pat wrote:
I'm having some problems with forms freezing up on me.

I have a front end linked to tables in 2 back ends. Users can open a form
(quotes) which is linked to
a table in be1. while adding a record to this form, the user can open a
form (stations) linked to a table in be2 which will generate a price, text
etc and insert info back into first form (quotes). This works.

The problem is that every so often the user opens the 2nd form in order to
update (change something)
and when he closes it, the 1st form freezes. - all the code runs, the info
on the first form is updated,
no error is generated, but the program is just frozen. you have to close it
(through taskmaster) and restart again in order to get access again.

Could the 2 different back ends be causing this. Does linking to different
be's from the same front end
cause issues?


No, using 2 backends is probably not causing this. Is the problem repeatable?

I'd try using debugging and step through your code. Perhaps there is some type of
unhandled error or an endless loop.

Perhaps one of the forms is corrupted or even the .mdb is corrupted.

Have you tried Compact and Repair (on a backup of your .mdb)?

Things get more drastic from there. You might need to import objects into a fresh .mdb
file or use the undocumented /decompile or the Application.SaveAsText() and
..LoadFromText() calls to remove corruption.

A search of this newsgroup will yield lots of assistance.

--
'---------------
'John Mishefske
'---------------
Apr 26 '06 #2

P: n/a
Pat
The problem does not occur when a new record is created, but if form 2 is
used to update a record
the problem will occur at about 1 or 2 times every 10 times this is done. I
know that all of the
code has executed because the form 1 closes and form 2 refreshes, but the
user just can't access anything on the open form (1). not even the close
window x in the top of the window.

both backends have be compact/repaired. front end also

"John Mishefske" <jm**********@SPAMyahoo.com> wrote in message
news:Wk**************@tornado.rdc-kc.rr.com...
Pat wrote:
I'm having some problems with forms freezing up on me.

I have a front end linked to tables in 2 back ends. Users can open a form (quotes) which is linked to
a table in be1. while adding a record to this form, the user can open a
form (stations) linked to a table in be2 which will generate a price, text etc and insert info back into first form (quotes). This works.

The problem is that every so often the user opens the 2nd form in order to update (change something)
and when he closes it, the 1st form freezes. - all the code runs, the info on the first form is updated,
no error is generated, but the program is just frozen. you have to close it (through taskmaster) and restart again in order to get access again.

Could the 2 different back ends be causing this. Does linking to different be's from the same front end
cause issues?
No, using 2 backends is probably not causing this. Is the problem

repeatable?
I'd try using debugging and step through your code. Perhaps there is some type of unhandled error or an endless loop.

Perhaps one of the forms is corrupted or even the .mdb is corrupted.

Have you tried Compact and Repair (on a backup of your .mdb)?

Things get more drastic from there. You might need to import objects into a fresh .mdb file or use the undocumented /decompile or the Application.SaveAsText() and .LoadFromText() calls to remove corruption.

A search of this newsgroup will yield lots of assistance.

--
'---------------
'John Mishefske
'---------------

Apr 26 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.