By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,426 Members | 2,753 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,426 IT Pros & Developers. It's quick & easy.

DoCmd.Beep - No Beep???

P: n/a
I have never used the DoCmd.Beep method and as far as I can tell all I
need to do is enter "DoCmd.Beep". I put this behind a buttons on
click and nothing. My sound is working. The computers beep sound is
working, but this isn't. Is there something I am missing?

Any help is appreciated
Apr 19 '06 #1
Share this Question
Share on Google+
4 Replies


P: n/a
use API instead.

Here's the code
Option Compare Database
************************************************** **************************************************
Private Declare Function Beep Lib "kernel32" (ByVal Btone As Long,
ByVal Blength As Long) As Long
************************************************** **************************************************
Public Sub BeepOnce()
Beep 1000, 300
End Sub
************************************************** **************************************************

Apr 20 '06 #2

P: n/a
Thank you very much. Cute how changing the numbers after Beep changes
the tone and timing. Could you tell me a good starting point to learn
this API stuff?

Thanks again.

On 19 Apr 2006 20:33:19 -0700, ar********@gmail.com wrote:
use API instead.

Here's the code
Option Compare Database
************************************************* ************************************************** *
Private Declare Function Beep Lib "kernel32" (ByVal Btone As Long,
ByVal Blength As Long) As Long
************************************************* ************************************************** *
Public Sub BeepOnce()
Beep 1000, 300
End Sub
************************************************* ************************************************** *


Apr 20 '06 #3

P: n/a
"Shyguy" <sh****@aol.com> wrote in message
news:or********************************@4ax.com...
I have never used the DoCmd.Beep method and as far as I can tell all I
need to do is enter "DoCmd.Beep". I put this behind a buttons on
click and nothing. My sound is working. The computers beep sound is
working, but this isn't. Is there something I am missing?

Any help is appreciated


This has worked for me...

Public Sub FZBeep()
Dim i as Integer
For i=1 to 300
DoCmd.Beep
Next
End Sub

Fred Zuckerman
Apr 20 '06 #4

P: n/a
"Fred Zuckerman" <Zu********@sbcglobal.net> wrote in message
news:GP*******************@newssvr11.news.prodigy. com...

This has worked for me...

Public Sub FZBeep()
Dim i as Integer
For i=1 to 300
DoCmd.Beep
Next
End Sub

Fred Zuckerman


OUCH! ;-)
Apr 26 '06 #5

This discussion thread is closed

Replies have been disabled for this discussion.