By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,650 Members | 1,976 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,650 IT Pros & Developers. It's quick & easy.

Can't create one-to-many relationships

P: n/a
I know this has been posted elsewhere, but none of the fixes in those
posts seems to address the problem I have.

First some background;
I have two tables, Exp_info (containing the field "ExpID" among others)
and Chip_info which also has a ExpID field and also a ChipID field. An
Experiment can have multiple ChipIDs associated with it, but a ChipID
can belong to only one experiment. i.e. a one to many relationship.

I can drag ExpID from Exp_info over to the ExpID field in Chip_info,
check the Enforce Ref Intergrity box. When I hit create, Access just
seems to sit there and do nothing. Creating Relationship... appears in
the status bar, but 10 mins goes by an no relationship is created.
There are no primary keys defined in either table and I have set all
indexed values to No for the ExpID fields. I have tried with completely
empty tables and tables with data.

It's driving me nuts. Any ideas.
Tony

Apr 18 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Why don't you make the unique id fields the primary key of the records, and
try again. Don't make the ExpID field the primary key of the Chip_info
table... put a field in to use as a Foreign Key to the Exp_info -- where you
will store a copy of the ExpID key of the related Exp_info table.

Larry Linson
Microsoft Access MVP
<a.********@talk21.com> wrote in message
news:11**********************@j33g2000cwa.googlegr oups.com...
I know this has been posted elsewhere, but none of the fixes in those
posts seems to address the problem I have.

First some background;
I have two tables, Exp_info (containing the field "ExpID" among others)
and Chip_info which also has a ExpID field and also a ChipID field. An
Experiment can have multiple ChipIDs associated with it, but a ChipID
can belong to only one experiment. i.e. a one to many relationship.

I can drag ExpID from Exp_info over to the ExpID field in Chip_info,
check the Enforce Ref Intergrity box. When I hit create, Access just
seems to sit there and do nothing. Creating Relationship... appears in
the status bar, but 10 mins goes by an no relationship is created.
There are no primary keys defined in either table and I have set all
indexed values to No for the ExpID fields. I have tried with completely
empty tables and tables with data.

It's driving me nuts. Any ideas.
Tony

Apr 18 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.