By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,483 Members | 1,909 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,483 IT Pros & Developers. It's quick & easy.

Bound Text Box Dropping Numbers

P: n/a
I have a replicated split database application I have created to
collect data. I have a form created that collects data from a barcode
scanner and a weight scale. The form has a MS Graph on it that is
updated after each new record is added. My problem is when I scan in a
barcode into the bound text box, about 1 in 100 scans results in a
misread. Most of the time a digit is missing from the somewhere in the
middle of the 11 digit sequence. The barcode is the primary key and
the scanner acts just like a keyboard. The scale runs a macro that
sends data by DDE to the query that the form is pulling from. I
noticed that when the barcode is being scanned, the graph will shade
grey until the barcode is finished entering. I can also recreate this
without the scanner by typing into the box very quickly. However, if I
type one character and then pause and then type as fast as possible the
graph does not shade. It is almost like that initial keystroke causes
the addition of the new record which loads up the computer and then it
takes it a second to get back to processing.

The main problem is that while scanning the 11 digit barcode I am
getting missing digits. It seems as if the focus is being taken off
the text box for a split second and then returning.

Any ideas would sure be helpfull. Right now I have a length check on
the text box that catches all the misreads before update, but it should
would be helpfull to find a fix.

Thanks.

Apr 18 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.