467,877 Members | 1,176 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,877 developers. It's quick & easy.

Tony Toews Auto FE Updater Problem

Hi I'm trying to use the Auto FE updater for the first time and am running
into a few problems.

1) 'UNC names on client path 'path' currently not supported.' I've mailed our
helpdesk to see if this is a netwrok thing but have not had a response. I am
sure in the past that they said UNC's were not a problem.

2) In the meantime I tried using a local address/ini just to see it I could
set it up. The local ini file passed validation but then I get another error
message:

"Error Copying File Or Folder" _
"Cannot copy AutoFEUpdater: It is being used by another person or program" _
"Close any programs that might be using the file and try again" _

When I click OK, it just opens the database.

I have tried removing AutoFEUpdater and starting from scratch but get the
same message.

Any assistance welcome.

Thanks

--
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200604/1
Apr 11 '06 #1
  • viewed: 1873
Share:
8 Replies
I'm having a very blonde day, been working to hard.

OK, update, got past this and now have new questions:

1) In the ini file MainApp= the workstation FE address? If that's true then
do I need an ini file for each FE or have I missed something??

2) On the users workstation I belive I'm setting the shortcut to StartMDB.exe
but need to make it run the ini.file. Can someone give me an example to work
from. (I've not tried the cmd before)

Thanks

--
Message posted via http://www.accessmonster.com
Apr 11 '06 #2
Like I said.... blonde day.

Got it working.

darrensawyer wrote:
I'm having a very blonde day, been working to hard.


--
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200604/1
Apr 11 '06 #3
Darren,

Wanna post your errors and solutions here? Then when someone runs into
the same problems they'll also see the solutions...

Jeremy

Apr 11 '06 #4
No Problem.

Initially I had incorrectly set the MainApp to the master FE, instead of the
User FE. This sorted out the first set of issues.

The next ones relate to the shortcut, I did not enter the path for the ini
file.
e.g. StartMDB.exe /cmd /inifile:"c:\test\ini\startmdb.ini"

Individual ini's are not required for each user if you use some generic path
for their copy (MainApp)
e.g. c:\DatabaseName.

This path should work for all as long as the system administrators allow
writing to the c:drive of the workstations.

Hope this is of use. The bottom line is I should have read Tony's text a
little more carefully before rushing in..
Jeremy Wallace wrote:
Darren,

Wanna post your errors and solutions here? Then when someone runs into
the same problems they'll also see the solutions...

Jeremy


--
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200604/1
Apr 11 '06 #5
"darrensawyer via AccessMonster.com" <u11419@uwe> wrote in
news:5ea011a0f0597@uwe:
The next ones relate to the shortcut, I did not enter the path for
the ini file.
e.g. StartMDB.exe /cmd /inifile:"c:\test\ini\startmdb.ini"

Individual ini's are not required for each user if you use some
generic path for their copy (MainApp)
e.g. c:\DatabaseName.

This path should work for all as long as the system administrators
allow writing to the c:drive of the workstations.


It would be better to use something like %USERPROFILE% for the
location of the front end. That will always be writable whether or
not the user is an administrator (which they should never be in a
secure environment).

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Apr 11 '06 #6
Hi David

Ini files are all new to me but I think I get where you are coming from. I'll
investigate further.

Thanks



--
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200604/1
Apr 12 '06 #7
"darrensawyer via AccessMonster.com" <u11419@uwe> wrote in
news:5ea91f4a0b6b7@uwe:
Ini files are all new to me but I think I get where you are coming
from. I'll investigate further.


The use of the environment variable is not an INI file issue. Simply
replace the path you're using with the environment variable in the
value stored in the INI file, and it should work (you'll have to
test whether the variable has a trailing backslash). To concatenate,
you just do something like "%USERPROFILE%\AccessFiles\" which when
it runs will replace the variable with the stored environment
variable.

This is simple old-fashioned DOS batch file technique.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Apr 12 '06 #8
Everyone should check this out: a beautiful solution by Danny
http://www.databasejournal.com/featu...le.php/3286111

darren via AccessMonster.com wrote:
Hi I'm trying to use the Auto FE updater for the first time and am running
into a few problems.

1) 'UNC names on client path 'path' currently not supported.' I've mailed our
helpdesk to see if this is a netwrok thing but have not had a response. I am
sure in the past that they said UNC's were not a problem.

2) In the meantime I tried using a local address/ini just to see it I could
set it up. The local ini file passed validation but then I get another error
message:

"Error Copying File Or Folder" _
"Cannot copy AutoFEUpdater: It is being used by another person or program" _
"Close any programs that might be using the file and try again" _

When I click OK, it just opens the database.

I have tried removing AutoFEUpdater and starting from scratch but get the
same message.

Any assistance welcome.

Thanks

--
Message posted via AccessMonster.com
http://www.accessmonster.com/Uwe/For...ccess/200604/1


Apr 14 '06 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Nathaniel Branden | last post: by
reply views Thread by msnews.microsoft.com | last post: by
9 posts views Thread by reshugoyal | last post: by
1 post views Thread by Rick | last post: by
3 posts views Thread by Don Barton | last post: by
2 posts views Thread by bobh | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.