By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,389 Members | 2,044 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,389 IT Pros & Developers. It's quick & easy.

Pivot Chart - inability to prevent rounding of data (Access 2003)

P: n/a

I've created a form that contains a single unbound combo box and two
subforms. The two subforms display the results of a query (driven by
the combo box selection) in both tabular and pivot chart formats. The
problem that I'm having is that the Pivot Chart that I've created
rounds all of the values down to the nearest integer (e.g., 1.9 is
rounded to 1.0, 0.6 is rounded to 0). As you can guess, this is a
serious issue when I'm trying to display the history of price paid for
inexpensive items over the last several months.

A couple things to note for troubleshooting:
1. The results of the tabular formatted subform remains accurate and
unrounded, displaying a full two digits after the decimal point
2. The underlying query for both subforms is exactly the same as is the
formatting, field properties, etc...
3. I've checked the properties on both subforms, the relevant values
(i.e., average price per unit) are set to "Currency", decimal places
set to "Auto"
4. I've changed the decimal place properties to "2" and this doesn't
make a difference on the Pivot Chart

I did a search on this in this groups archives but couldn't find
anything relevant, apologies if this is repetitive. Any direction you
can provide would be welcome.

By the way, how does one get around posting a valid email address in
this forum (I'm using Google Groups, which might be the issue)?

Mar 14 '06 #1
Share this Question
Share on Google+
1 Reply

P: n/a
Just an FYI for interested readers that the problem has been solved by
changing the setting of the table level data to single from long
integer for a field that was overlooked.


Mar 17 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.