By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,490 Members | 1,789 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,490 IT Pros & Developers. It's quick & easy.

Access 2003 Error Distributing .mdb

P: n/a

I recently built an Access 2003 database on my workstation. I have a
client .mdb file with my forms/code, which links tables from an .mdb on
our server. When I copy the client .mdb to a user's workstation and
use it, the links are fine but I get an error on the following line:

Line: Me.txtWhen = Now
Error: "You can't assign a value to this object"
From what I can tell the machines have the same OS, Access version

(2003), and Jet engine. The library references are the same except
that the user's workstation has a different file version for 'Visual
Basic For Applications' (VBE6.dll

First, is simply copying the .mdb the way to distribute the app?

Second, any ideas on why that line of code is breaking?

I'm new to Access so any help is greatly appreciated.


Feb 27 '06 #1
Share this Question
Share on Google+
2 Replies

P: n/a
First, my answer would be yes, although it might not be the most
sophisticated way to do it.
Second, IMHO, your code breaking on that line is not related to the
first, but might be due to the fact that you already directly entered a
value in Me.txtWhen in Design View. In that case, deleting that value
should solve your problem.

Feb 28 '06 #2

P: n/a
"richp" <rp*******> wrote in
Line: Me.txtWhen = Now
Error: "You can't assign a value to this object"

Open the database, hit Ctrl-G on the keyboard, and in the VBE
window, go to the Tools menu and check REFERENCES. My bet is that
one or more will be marked MISSING. This is because it's not in a
location compatible with the other machine, or because the external
library isn't there at all.

David W. Fenton
usenet at dfenton dot com
Feb 28 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.