By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,530 Members | 2,181 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,530 IT Pros & Developers. It's quick & easy.

Query Truncates Memo Fields

P: n/a
I have a query that combines the results of three related tables. The
memo fields are truncated to 255 characters, but I need all the
information in them. I'm aware that removing code such as DISTINCT and
GROUPBY will fix this problem (as discussed in other threads in this
group), but I need to limit the query results to unique values, which
is what DISTINCT does for me. Any suggestions?
Thanks,
Jacob

Feb 16 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
In a GROUP BY query, you can get the whole memo field by choosing First
instead of Group By in the total row under your memo field.

For a query that uses DISTINCT, omit the memo fields. Save the query. Then
use it as a source "table" in another query, joined to the one that contains
the memo. Since this new query is not using DISTINCT, you can now pull in
the entire memo field.

If you are actually trying to de-duplicate based on the contents of the memo
fields, you are out of luck. Access will compare the first 255 characters of
the memo only.

--
Allen Browne - Microsoft MVP. Perth, Western Australia.
Tips for Access users - http://allenbrowne.com/tips.html
Reply to group, rather than allenbrowne at mvps dot org.

<ja********@gmail.com> wrote in message
news:11*********************@g47g2000cwa.googlegro ups.com...
I have a query that combines the results of three related tables. The
memo fields are truncated to 255 characters, but I need all the
information in them. I'm aware that removing code such as DISTINCT and
GROUPBY will fix this problem (as discussed in other threads in this
group), but I need to limit the query results to unique values, which
is what DISTINCT does for me. Any suggestions?
Thanks,
Jacob

Feb 16 '06 #2

P: n/a
Thanks. This is working great.
Jacob

Feb 16 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.