By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,510 Members | 1,437 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,510 IT Pros & Developers. It's quick & easy.

StartRow in Import/Export Specifications

P: n/a
I have created a couple of Importspecifications which I use in my code
to let users import files into my Access database. In the code I set
the property 'HasFieldNames' of the function 'DoCmd.TransferText' to
False. But when users import files, for some files it skips the first
record despite using the setting 'HasFieldNames' at 'False'.

When I look in the table MSysIMEXSpecs I can see a column Startrow
which contains a 1 for these files...

1) How can I change this? It doesn't seem possible by using the
'Advanced' button in the import sequence.
2) How can I influence this setting when I create an Import
specification?
Grtz,
Freddy

Jan 19 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Freddy:

One option for changing the StartRow value is by using a query. For
example:

UPDATE MSysIMEXSpecs SET MSysIMEXSpecs.StartRow = 0
WHERE (((MSysIMEXSpecs.SpecID)=1));

Of course, you will need the appropriate permissions on the table. I
believe the StartRow value toggles between zero and one in the wizard
depending on the value of the HasFieldNames checkbox, although I believe it
will accept other values that are set manually.

--
David Lloyd
MCSD .NET
http://LemingtonConsulting.com

This response is supplied "as is" without any representations or warranties.
"Freddy" <fr*************@gmail.com> wrote in message
news:11**********************@o13g2000cwo.googlegr oups.com...
I have created a couple of Importspecifications which I use in my code
to let users import files into my Access database. In the code I set
the property 'HasFieldNames' of the function 'DoCmd.TransferText' to
False. But when users import files, for some files it skips the first
record despite using the setting 'HasFieldNames' at 'False'.

When I look in the table MSysIMEXSpecs I can see a column Startrow
which contains a 1 for these files...

1) How can I change this? It doesn't seem possible by using the
'Advanced' button in the import sequence.
2) How can I influence this setting when I create an Import
specification?
Grtz,
Freddy
Jan 20 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.