By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,209 Members | 1,100 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,209 IT Pros & Developers. It's quick & easy.

Is there a way to disable the F-11 key to prevent runtime installations from opening the database window?

P: n/a
MLH
If I give someone a runtime app,
they can open the database
window by pressing the F-11
key. How to prevent???
Dec 23 '05 #1
Share this Question
Share on Google+
16 Replies


P: n/a
Bri

MLH wrote:
If I give someone a runtime app,
they can open the database
window by pressing the F-11
key. How to prevent???


This is another perfect example of what I and others have been trying to
tell you. Type Disable F11 into the Help assistand and you are give the
one and only help topic that answers how to do this. Took me exactly 2
seconds to find it, much less time than it took for you to type this.
Have you ever tried using the help file? It really does have help in it.
Try it out. Please!

--
Bri

Dec 23 '05 #2

P: n/a
MLH
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.
Dec 23 '05 #3

P: n/a
MLH wrote in message <2c********************************@4ax.com> :
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.


When I followed Bri's instructions (type "Disable F11" ...) on my
installation of a97, I got two entries returned. Both seem relevant.

--
Roy-Vidar
Dec 23 '05 #4

P: n/a

"MLH" <CR**@NorthState.net> wrote in message
news:2c********************************@4ax.com...
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.

I no longer have A97 installed. Do you have an AllowSpecialKeys property?

--
Randy Harris
tech at promail dot com
I'm pretty sure I know everything that I can remember.
Dec 24 '05 #5

P: n/a
MLH
I see the following in another thread I started
and lost a couple of days earlier. Free Agent
sometimes is not everything I wish it were. If
I lose a thread - I have no clue how to get it
back again. So I googled and found paii, Ron
and Wayne Gillespie so graciously responded to my
Q...

To answer first, Wayne Gillespie - you were right.
The target machine DID have A97 installed on it.
I didn't realize all one had to do if one wished to
see the database window is to install A97 on the
machine running the runtime app. If that's all one
has to do, there's not much point in disabling it unless
you know for certain that target machines are not
running A97. Hmmm??? I could never say that with
certainty.

Now, for Ron Paii - can I implement what you suggested
programatically from code? What if I want the F-11 utility
or to open a debug window or pause execution - and I
choose to allow it if I'm the logged in user? I may even
base it on group membership. Can that be done?

MLH
Dec 21, 1:26 pm show options
Subject: A97 Runtime - I wish to disable F-11 key from displaying
database window

I did not know pressing F-11 key would open database
window in a runtime installation. I found it out by accident
today. How might I prevent this undesirable event?
Reply
paii, Ron
Dec 21, 1:39 pm show options

Newsgroups: comp.databases.ms-access
From: "paii, Ron" <p...@packairinc.com> - Find messages by this author
Date: Wed, 21 Dec 2005 12:39:58 -0600
Local: Wed, Dec 21 2005 1:39 pm
Subject: Re: A97 Runtime - I wish to disable F-11 key from displaying
database window
Reply | Reply to Author | Forward | Print | Individual Message | Show
original | Report Abuse

2 ways, I use both!
1) Create a macro called "AutoKeys"
Under the Macro Name column create one called "{F11}" and assign
some do
nothing action.
2) In the database startup uncheck "Use Access Special Keys", visible
if you
click the Advanced button.

"MLH" <C...@NorthState.net> wrote in message
news:vf********************************@4ax.com...
- Hide quoted text -
- Show quoted text -
I did not know pressing F-11 key would open database
window in a runtime installation. I found it out by accident
today. How might I prevent this undesirable event?

Reply
paii, Ron
Dec 21, 1:44 pm show options

Newsgroups: comp.databases.ms-access
From: "paii, Ron" <p...@packairinc.com> - Find messages by this author
Date: Wed, 21 Dec 2005 12:44:45 -0600
Local: Wed, Dec 21 2005 1:44 pm
Subject: Re: A97 Runtime - I wish to disable F-11 key from displaying
database window
Reply | Reply to Author | Forward | Print | Individual Message | Show
original | Report Abuse

Realize you will also need to disable the default menu and tool bars,
they
also provide the ability to unhide the database window.

"MLH" <C...@NorthState.net> wrote in message
news:vf********************************@4ax.com...
- Hide quoted text -
- Show quoted text -
I did not know pressing F-11 key would open database
window in a runtime installation. I found it out by accident
today. How might I prevent this undesirable event?

Reply
Wayne Gillespie
Dec 21, 6:16 pm show options

Newsgroups: comp.databases.ms-access
From: Wayne Gillespie <best...@NOhotmailSPAM.com.au> - Find messages
by this author
Date: Wed, 21 Dec 2005 23:16:54 GMT
Local: Wed, Dec 21 2005 6:16 pm
Subject: Re: A97 Runtime - I wish to disable F-11 key from displaying
database window
Reply | Reply to Author | Forward | Print | Individual Message | Show
original | Report Abuse

On Wed, 21 Dec 2005 13:26:21 -0500, MLH <C...@NorthState.net> wrote:I did not know pressing F-11 key would open database
window in a runtime installation. I found it out by accident
today. How might I prevent this undesirable event?

Are you sure you were running the db in a full runtime environment and
not on a machine with A97 installed?
In a true runtime environment the database window is never accessible
by ANY means.

Wayne Gillespie
Gosford NSW Australia
Reply
Dec 24 '05 #6

P: n/a
MLH
Good for you. Care to share the answer?
I typed Disable F-11, Disable F11, F11
Disable, f11 disable, disable f11 =>

nothing worked
sure would be nice if mine worked as good
as yours. But it doesn't. Seriously, though...
it doesn't really make that much difference.
It has been answered in another thread I
deleted by accident.
Dec 24 '05 #7

P: n/a
Happy Holidays from Google
Web Results 1 - 10 of about 67,600 for Disable F11 Access 97. (0.19
seconds)

*****

Go to Google Groups Home
Searched all groups Results 1 - 10 of 274 for Disable F11 Access 97
(0.15 seconds)

*****
Regardless I had no problem with your question as it was simple and
clear and without any clutter (eg. Does anyone know how to do a hard
disk write to byte 412 of an Access mdb to disable F-11?). I didn't
answer because I don't have Access 97and I couldn't remember if Access
97 works the way Access 2003 works with respect to this.

Dec 24 '05 #8

P: n/a
MLH
Yep. T'was hiding in the startup properties. Thx.

I no longer have A97 installed. Do you have an AllowSpecialKeys property?


Dec 24 '05 #9

P: n/a
Bri

MLH wrote:
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.


I am using AC97 SP2.

F1 for the Help assistant
Disable F11 - One topic returned
Disable F-11 - Many topics returned, had to look at them to see which
one was pertinent

If this doesn't work for you then I sugggest that you reinstall Access
(or run the install checker) as there is something wrong with your help
files. While you are there select all the options for all of the
advanced help (gets you VBA help).

Something wrong with your help files could explain a few things.

--
Bri

Dec 24 '05 #10

P: n/a
MLH <CR**@NorthState.net> wrote in
news:2c********************************@4ax.com:
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.


You're ignoring the index. If you open help, there are three tabs.
The full-text search is on the 3rd tab. This is where you need to
type the search phrase.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Dec 24 '05 #11

P: n/a
MLH
Wow. I'm glad I posted here.
I got my answer after reading
only about 3 lines one guy
tossed out - seemingly not
bothered at all about the
fact that there were 67000
other doors I could-a-knocked on.
Dec 24 '05 #12

P: n/a
MLH
On Sat, 24 Dec 2005 00:25:32 GMT, Bri <no*@here.com> wrote:

MLH wrote:
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.
I am using AC97 SP2.

I am using AC97 SP1 Build 2600
F1 for the Help assistant
Disable F11 - One topic returned
Disable F-11 - Many topics returned, had to look at them to see which
one was pertinent Yeah and if I type the same thing, the annoying little
paperclip prick just makes faces at me asking what
would you like to do and each time I click search it
re-starts the cycle. OK. Whats the point? So I'll get
around to fixing it one day. In the meanwhile, I'll ask
questions and beg the forgiveness of those of you
who are annoyed by it.

If this doesn't work for you then I sugggest that you reinstall Access
(or run the install checker) as there is something wrong with your help
files. While you are there select all the options for all of the
advanced help (gets you VBA help).

Something wrong with your help files could explain a few things.


Dec 24 '05 #13

P: n/a
MLH
On Fri, 23 Dec 2005 20:12:31 -0600, "David W. Fenton"
<XX*******@dfenton.com.invalid> wrote:
MLH <CR**@NorthState.net> wrote in
news:2c********************************@4ax.com :
Does anybody else care to comment.
Access 97 says nothing about F-11.
Obviously Bri is not using my installation
of A97 or my HELP.


You're ignoring the index. If you open help, there are three tabs.
The full-text search is on the 3rd tab. This is where you need to
type the search phrase.

Yep. You are exactly right. There it was. I've always used the middle
tab. It found a lot more than I would likely have read, as one of my
virtues is not reading - I find it frustrating to traverse too much
material to get to an answer. The PROBLEM is no longer the
problem, if you know what I mean. The PROBLEM turns into a
a mountain of text to excavate in order to find an ant-hill of
solution.

Sorry, I'm just being real. That's the way it is with me.
Thank-you for giving me a heads-up on he 3rd tab.
I'll make more use of it.
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

Enable or disable keys that display the Database or Debug windows,
menu bars, or modules
1 On the Tools menu, click Startup.

Show me

2 Click Advanced.
3 Clear or select the Use Access Special Keys check box to
enable or disable the following keys.

Keys Result
F11 or ALT+F1 Brings the Database window to the front
CTRL+G Brings up the Debug window
CTRL+F11 Toggles between the custom menu bar and the built-in
menu bar
CTRL+BREAK Stops code from executing and displays the current
module in the Module window
Notes

Changes to this setting in the Startup dialog box won't take
effect until the next time the database or application is opened.
Whether or not you select the Use Access Special Keys check
box, if you select the Allow Viewing Code After Error check box you
can display the Module window to debug code after a run-time error
occurs.
If you clear the Use Access Special Keys check box and you
specify a custom menu bar in the Menu Bar box, the built-in menu bar
isn't accessible.

If you clear both the Use Access Special Keys check box and
the Display Database Window check box, it's possible that users can
still access the Database window. This can happen when a user tries
more than once to open the same database from the list of
most-recently-used databases, which automatically appears on the File
menu. To prevent users from accessing this list, replace the File menu
with your own custom menu.
For a list of issues to consider when setting options in the
Startup dialog box, click .
Dec 24 '05 #14

P: n/a
MLH <CR**@NorthState.net> wrote in
news:r4********************************@4ax.com:
Sorry, I'm just being real. That's the way it is with me.


Well, if that's the real you, I'm not interested in helping the real
you, since the statement above makes you look like a lazy wanker.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Dec 24 '05 #15

P: n/a
MLH <CR**@NorthState.net> wrote in
news:9c********************************@4ax.com:
Wow. I'm glad I posted here.
I got my answer after reading
only about 3 lines one guy
tossed out - seemingly not
bothered at all about the
fact that there were 67000
other doors I could-a-knocked on.


Do your own homework, the way the rest of us have done it.

Look in Access Help (you're using the very best version of Access
Help there ever was -- it's all downhill after A97), and Google
Groups. If you don't find anything *then* post here. Or if what you
find doesn't make any sense, or you can't figure out how to make
what you find work.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Dec 24 '05 #16

P: n/a
MLH <CR**@NorthState.net> wrote in
news:vj********************************@4ax.com:
On Sat, 24 Dec 2005 00:25:32 GMT, Bri <no*@here.com> wrote:
F1 for the Help assistant
Disable F11 - One topic returned
Disable F-11 - Many topics returned, had to look at them to see
which one was pertinent


Yeah and if I type the same thing, the annoying little
paperclip prick just makes faces at me asking what
would you like to do and each time I click search it
re-starts the cycle. OK. Whats the point? So I'll get
around to fixing it one day. In the meanwhile, I'll ask
questions and beg the forgiveness of those of you
who are annoyed by it.


The fact that you use the frigging paperclip is yet another piece of
evidence that you are just a complete idiot.

Turn it off and you will have a much more user-friendly program.

--
David W. Fenton http://www.dfenton.com/
usenet at dfenton dot com http://www.dfenton.com/DFA/
Dec 24 '05 #17

This discussion thread is closed

Replies have been disabled for this discussion.