By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,491 Members | 1,868 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,491 IT Pros & Developers. It's quick & easy.

Delete relationship

P: n/a
I deleted a relationship in the relationship view, but when I create a
query that includes those two tables, the relationship reappears. When
I go back to the relationship view there is NO relationship but I can't
seem to get rid of it for queries (without manually doing it for each
query). Can anyone tell me whats going on??? TIA

Nov 13 '05 #1
Share this Question
Share on Google+
7 Replies


P: n/a

"francophone77" <fr***********@hotmail.com> wrote in message
news:11*********************@g47g2000cwa.googlegro ups.com...
I deleted a relationship in the relationship view, but when I create a
query that includes those two tables, the relationship reappears. When
I go back to the relationship view there is NO relationship but I can't
seem to get rid of it for queries (without manually doing it for each
query). Can anyone tell me whats going on??? TIA


When viewing your relationships, right-click and choose Show All. I would
expect the relationship to appear even if you have to move tables or search
a bit to see it. In other words the rlationship *is* there it's just not
currently being shown. What you deleted was an additional realtionship you
set up.
<that's the theory anyway>
Nov 13 '05 #2

P: n/a
I forgot to mention that I DID do a show all and in fact deleted all
relationships just to make sure. But no matter what, that relationship
always shows up when I bring both tables into one query.

Nov 13 '05 #3

P: n/a
"francophone77" <fr***********@hotmail.com> wrote in message
news:11**********************@z14g2000cwz.googlegr oups.com...
I forgot to mention that I DID do a show all and in fact deleted all
relationships just to make sure. But no matter what, that relationship
always shows up when I bring both tables into one query.

If the fields share the same name
and the same datatype
and one of the fields is a primary key
and Tools>Options>Tables/Queries>Enable Autojoin is selected
Then the join will appear - so turn it off if you don't want this feature.

If you suspect something is not as it should be try creating a new database
and importing all the tables (but make sure under the options section that
you choose not to import the relationships). Then you can re-create the
relationships from scratch.
Nov 13 '05 #4

P: n/a

"francophone77" <fr***********@hotmail.com> wrote in message
news:11*********************@g47g2000cwa.googlegro ups.com...
I deleted a relationship in the relationship view, but when I create a
query that includes those two tables, the relationship reappears. When
I go back to the relationship view there is NO relationship but I can't
seem to get rid of it for queries (without manually doing it for each
query). Can anyone tell me whats going on??? TIA


Hi

Tools > Options, on Table/Queries tab, Query Design - tick box Enable Auto
Join is probably ticked.

- Joe
Nov 13 '05 #5

P: n/a
"francophone77" <fr***********@hotmail.com> schreef in bericht news:11**********************@z14g2000cwz.googlegr oups.com...
I forgot to mention that I DID do a show all and in fact deleted all
relationships just to make sure. But no matter what, that relationship
always shows up when I bring both tables into one query.


Perhaps Access is trying to be smart ...
-- Is this 'relationship' an innerjoin between two fields with the same name?
-- Both fields are also primary keys?

Arno R
Nov 13 '05 #6

P: n/a
Thanks, AutoJoin WAS enabled.

Nov 13 '05 #7

P: n/a
francophone77 wrote:
Thanks, AutoJoin WAS enabled.


Now restore the backup that had all the relationships in before you sod
up the whole database.
Nov 14 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.